Hello! I tried to install CUDA 5 on my ubuntu 12.4 with GeForce 210

Hello!

I tried to install CUDA 5 on my ubuntu 12.4 64bit with GeForce 210 is not working so I have to go with the installation of CUDA 4 from https://help.ubuntu.com/community/Cuda and i have get an error in that, can you help me

Motherboard - GIGABYTE - GA-G31M-S2L with PCI-E x16
processor -Intel Core2 Duo CPU E7300 @ 2.66GHz x 2
Memory - 4 GB
OS type - 64-bit ubuntu 12.4
with
GeForce 210 - GIGABYTE compatible with PCI-E 3.0 Motherboard and running at PCI-E 2.0 speed

in CUDA 5

chmod +x cuda_5.0.35_linux_64_rhel5.x-1.run
sudo ./cuda_5.0.35_linux_64_rhel5.x-1.run

the error with CUDA 5

nstalling the NVIDIA display driver...

===========
= Summary =
===========

Driver:   Installation Failed
Toolkit:  Installation skipped
Samples:  Installation skipped

Logfile is /tmp/cuda_install_5413.log

the error with CUDA 4 by going through the steps of installation from https://help.ubuntu.com/community/Cuda

to Installation of CUDA Toolkit i have to type

sudo apt-get install libxi-dev libxmu-dev freeglut3-dev build-essential binutils-gold

Downloads

64bits:

cd ~/Desktop
wget http://developer.download.nvidia.com/compute/cuda/4_2/rel/toolkit/cudatoolkit_4.2.9_linux_64_ubuntu11.04.run
wget http://developer.download.nvidia.com/compute/cuda/4_2/rel/sdk/gpucomputingsdk_4.2.9_linux.run
cd ~/Desktop
chmod +x cudatoolkit_4.2.9_linux_*
sudo ./cudatoolkit_4.2.9_linux_*
Enter install path (default /usr/local/cuda, '/cuda' will be appended):

i Enter “/opt”

and the result
========================================

* Please make sure your PATH includes /opt/cuda/bin
* Please make sure your LD_LIBRARY_PATH
*   for 32-bit Linux distributions includes /opt/cuda/lib
*   for 64-bit Linux distributions includes /opt/cuda/lib64:/opt/cuda/lib
* OR
*   for 32-bit Linux distributions add /opt/cuda/lib
*   for 64-bit Linux distributions add /opt/cuda/lib64 and /opt/cuda/lib
* to /etc/ld.so.conf and run ldconfig as root

* Please read the release notes in /opt/cuda/doc/

* To uninstall CUDA, remove the CUDA files in /opt/cuda
* Installation Complete

so i have typed:

sudo rm -r /opt/cuda

and again

chmod +x cudatoolkit_4.2.9_linux_*
sudo ./cudatoolkit_4.2.9_linux_*
Enter install path (default /usr/local/cuda, '/cuda' will be appended):

i Enter "/opt"

the result it’s same like before

so install the Installation of GPU Computing SDK

chmod +x gpucomputingsdk_4.2.9_linux.run
./gpucomputingsdk_4.2.9_linux.run

When it will ask you:

Enter install path (default ~/NVIDIA_GPU_Computing_SDK):

press [enter] (to use default path), and type /opt when it will ask you:

Enter CUDA install path (default /usr/local/cuda):

but when i type /opt the

Enter CUDA install path (default /usr/local/cuda): /opt
touch: cannot touch `/home/kedh/NVIDIA_GPU_Computing_SDK/empty': Permission denied
* Unable to write to directory /home/kedh/NVIDIA_GPU_Computing_SDK.
* Installation Aborted

Thanks

May I ask what the problem was when installing CUDA 5?

For the current issue, do you have any special permissions on your home directory? The installer is probably trying to install a writable copy of the SDK Samples and, for some reason, doesn’t have write permissions. Can you run the installer with sudo, or change the permissions of /home/kedh?

Feel free to ask, thanks for asking and helping me out

that was long time since i have install CUDA 5 around a Month, Now i’m going back to do that again.
as i remember i was having compiling issue

I’m new in ubuntu, first attempt

special permissions on my home directory? what you mean?
i don’t think that i have any special permissions,
if i do any installation only i have to type my password for authenticate

yes, i’m run the installation on the terminal by using sudo,
and when I install the driver for NVIDIA GeForce 210
i have use:

sudo srevice lightdm stop

to the end of the installation and i have NVIDIA X server

but if I go to ubuntu System Settings>Details
it say that “Graphics Unknown” and when i ask they say it is normal

Again tried CUDA 5 and it failed

and I have CHANGED the original post to reflect the problem with the CUDA 5 install

Can you post the contents of /tmp/cuda_install_5413.log, and the display driver log? The display driver log should be referenced in the first log. Thanks!

i don’t have the file anymore, so i had to install CUAD 5 again and it failed again and it generate a new Logfile /tmp/cuda_install_3072.log

nstalling the NVIDIA display driver...

===========
= Summary =
===========

Driver:   Installation Failed
Toolkit:  Installation skipped
Samples:  Installation skipped

Logfile is /tmp/cuda_install_3072.log

and the contents is

Using more to view the EULA.
Installing the NVIDIA display driver...

Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 304.54...............................................................................................................................................................

ERROR: You appear to be running an X server; please exit X before
       installing.  For further details, please see the section INSTALLING
       THE NVIDIA DRIVER in the README available on the Linux driver
       download page at www.nvidia.com.

ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find
       suggestions on fixing installation problems in the README available
       on the Linux driver download page at www.nvidia.com.

Welcome to the NVIDIA Software Installer for Unix/Linux

The file '/tmp/.X0-lock' exists and appears to contain the process ID
'1051' of a runnning X server.

===========
= Summary =
===========

Driver:   Installation Failed
Toolkit:  Installation skipped
Samples:  Installation skipped

Logfile is /tmp/cuda_install_3072.log

and this is the contents of /var/log/nvidia-installer.log

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Tue Dec  4 21:08:27 2012
installer version: 304.54

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

nvidia-installer command line:
    ./nvidia-installer
    --ui=none
    --no-questions
    --accept-license
    --disable-nouveau

Using built-in stream user interface
-> The file '/tmp/.X0-lock' exists and appears to contain the process ID '1051' of a runnning X server.
ERROR: You appear to be running an X server; please exit X before installing.  For further details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on the Linux driver download page at www.nvidia.com.
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

i’m using the ubuntu terminal with sudo
what is X server?? is that the “NVIDIA X Server Settings”
do i have go to login screen by Press Ctrl+Alt+F1 and type

sudo service lightdm stop

It seems you’re running X when trying to install CUDA 5.0. I know above for the CUDA 4 test you said you killed lightdm. Are you killing it for the CUDA 5.0 test as well? If you are, either X is loaded some other way…or you have an X lock file hanging around somewhere.

So make sure you’re killing X via stopping lightdm (try gdm too, just to be sure) before the CUDA 5.0 test:
sudo service lightdm stop
sudo service gdm stop

Then try the test again. If it still mentions the X file, see if you have X running with:
ps aux | grep X
This might shed some insight.

If X is not running, delete the lock file(s)
sudo rm /tmp/.X*-lock

it failed again

i have done the

sudo service lightdm stop

and the result

Rather than invoking init scripts through 
/etd/init.d, use the service(8) utility, e.g. service lightdm sotp

the script you are attempting to invoke has bee converted to an upstart job,
but sotp is not supported for upstart jobs

when i tried

sudo service gdm stop

result

gdm : unrecognized sevice

and i tried

sudo rm /tmp/.X*-lock

the result of ps aux | grep X is

root      1088  1.4  1.1 149924 47408 tty7     Ss+  21:55   0:15 /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none
kedh      2358  0.0  0.0  13580   928 pts/3    S+   22:13   0:00 grep --color=auto X

how to kill the X server,

i have search on Internet they say do

Ctrl+Alt+F1 and type:

sudo service gdm stop
sudo /etc/init.d/lightdm stop
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

is not work in my case

all filed,do i have to uninstall the NVIDIA X Server Settings, what is your suggestion

Well X needs to be down to install the driver, and stopping the gdm/lightdm service is the way to do this properly on Ubuntu.

Can you try to kill X one more time using the “sudo service gdm stop/sudo service lightdm stop” method and ensure that there are no /tmp/.X*-lock files. If there are, try killing the X process via a virtual terminal (the ugly terminals from ctrl + alt + F#) using the ‘kill’ command, then delete the .X*-lock files.

Then run the installer? If the install fails at this point it should be due to another reason, not X. Post the logs generated like before please.

The idea of what I’m trying to do here is bring X down, in any way possible, to get you set up. If you installed nvidia-current or nvidia-settings via apt-get, you’ll want to uninstall them as well.

it failed again

Using more to view the EULA.
Installing the NVIDIA display driver...

Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 304.54...............................................................................................................................................................

ERROR: You appear to be running an X server; please exit X before
       installing.  For further details, please see the section INSTALLING
       THE NVIDIA DRIVER in the README available on the Linux driver
       download page at www.nvidia.com.

ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find
       suggestions on fixing installation problems in the README available
       on the Linux driver download page at www.nvidia.com.

Welcome to the NVIDIA Software Installer for Unix/Linux

The file '/tmp/.X0-lock' exists and appears to contain the process ID
'1118' of a runnning X server.

===========
= Summary =
===========

Driver:   Installation Failed
Toolkit:  Installation skipped
Samples:  Installation skipped

Logfile is /tmp/cuda_install_2017.log

/var/log/nvidia-installer.log

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Dec  6 17:59:15 2012
installer version: 304.54

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

nvidia-installer command line:
    ./nvidia-installer
    --ui=none
    --no-questions
    --accept-license
    --disable-nouveau

Using built-in stream user interface
-> The file '/tmp/.X0-lock' exists and appears to contain the process ID '1118' of a runnning X server.
ERROR: You appear to be running an X server; please exit X before installing.  For further details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on the Linux driver download page at www.nvidia.com.
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

i have notes ‘The file ‘/tmp/.X0-lock’ exists and appears to contain the process ID
‘1118’ of a runnning X server’
and the old one ID is ‘1051’
so the file ‘/tmp/.X0-lock’ is exists there

by the way the file with this name ‘unity_support_test.0’ it’s exists at /tmp,
it’s not folder it’s file does it make any sense to you

now i going to try install Geforce 210 one more time, do i have to uninstall or it will be update?

finally some hope
The thing i have done is
I decided to do the installation after “sudo service lightdm stop”

so i used the (terminals from ctrl + alt + F1 or F2)

first step

sudo service lightdm stop

result

lightdm stop/witing

second step

chmod +x cuda_5.0.35_linux_64_rhel5.x-1.run
sudo ./cuda_5.0.35_linux_64_rhel5.x-1.run

result
Success with installation except the

Samples:  Installation Failed

This all makes sense. Sounds like you have the driver installed. Dig into the logs for the Samples - I’m guessing you’re missing libGLUT, or the symlink to libGLUT is broken.

Yes, I did installed the driver with the Toolkit but without the Samples,

and to install the Samples i have to do the Path Preparation, like what i had use with the old CUDA 4 was

export PATH=$PATH:/opt/cuda/bin

I am going to search for that after i’m done with my exam at the college

i will let you know what happened when it’s done.

I have learned from you and Thanks for your encouraging me to search

Thank Tamarzan.