Help with connecting Ip camera to jetson nano and to Azure IoT Edge

Hi,
my setup is:

  • Hardware Platform (Jetson Nano)
  • Deepstream Version 4.0.2
  • Jetpack Version 4.3
  • Dahua IP Camera

In my configuration file I have:

[sink3]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File 4=RTSPStreaming
type=4
#1=h264 2=h265
codec=1
sync=0
bitrate=4000000
# set below properties in case of RTSPStreaming
rtsp-port=8554
#udp-port=5400

I’m using Azure IoT edge and deepstream. The 4 modules; iotCentralBridge, deepstream, edgeAgent and edgeHub seems running correctly. With the “traffic video demo” I get the telemetry data in Azure IoT central and I can see the output video using VLC with the URL: rtsp://192.168.1.3:8554/ds-test

Now I want to use my own IP camera to do the same but I don’t know why it is not working.

I already checked that my camera is funtional using VLC but only as an input rtsp://admin:12345678W@192.168.1.108:554/cam/realmonitor?channel=1&subtype=1

Do somebody know what I’m missing to connect the Ip camera to the IoT edge?

I’m following this tutorial and I should get something like this.

Thank you.

Hi,
After connecting the IP camera and a TV through HDMI with Jetson Nano, please try the gstreamer pipeline:

$ gst-launch-1.0 uridecodebin uri=rtsp://admin:12345678W@192.168.1.108:554/cam/realmonitor?channel=1&subtype=1 ! nvoverlaysink

And check if you can see video preview.

Seems that I still can’t connect the IP camera to the Jetson Nano. I can’t see the video preview with a TV through HDMI. I get the error:

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://admin:12345678W@192.168.1.108:554/cam/realmonitor?channel=1
Progress: (open) Retrieving server options
Progress: (open) Retrieving media info
ERROR: from element /GstPipeline:pipeline0/GstURIDecodeBin:uridecodebin0/GstRTSPSrc:source: Could not open resource for reading.
Additional debug info:
gstrtspsrc.c(5829): gst_rtspsrc_setup_auth (): /GstPipeline:pipeline0/GstURIDecodeBin:uridecodebin0/GstRTSPSrc:source:
No supported authentication protocol was found
ERROR: pipeline doesn't want to preroll.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

Hi,
Please check

Since it fails in rtspsrc ! fakesink, it seems to be an issue in rtspsrc plugin. We would suggest go to gstreamer forum to get assistance.

Ok, I will, thanks