How to do Int8 calibration for Faster RCNN?

Description

I am facing some troubles for converting FRCNN model to int8 engine.

config->setFlag(BuilderFlag::kINT8);
builder->setInt8Mode(true);
nvinfer1::Dims dims{4, {8, 3, 600, 1000}, {}};
BatchStream calibrationStream(8,8,dims,"./data/calibraton/frcnn/list_images.txt", dataDirs);
calibrator.reset(new Int8EntropyCalibrator2<BatchStream>(
            calibrationStream, 0, "frcnn", "data"));
config->setInt8Calibrator(calibrator.get());

I am using the above code for setting up the calibrator for INT8.

../builder/cudnnCalibrator.cpp (724) - Cuda Error in add: 700 (an illegal memory access was encountered)

I am not getting any clue where I am going wrong.

Environment
TensorRT Version: 7
GPU Type: Tesla P100
Nvidia Driver Version: 440
CUDA Version: 11.0

Thanks in Advance,
Regards

Hi @nssreenivasalu,
Request you to take reference from the sample


However, to address teh error you are getting, you may check the below link.

Thanks!