How to enable double-precision on a GTX 280?


Can anyone help me to enable double-precision on a GTX 280?

I’ve found the following solution online:

“If you are working on a machine with a GPU that supports double-precision, add “–gpu-name sm_13” to the command line options passed to nvcc.”

However, it’s not clear how to do this. What file is this added to, and where?

Thanks for any advice.

PS. I’m using CUDA 2.0 with 32 bit Ubuntu.

If you have some cuda code, and you are compiling it you will have for sure some makefile, where a call to nvcc (the cuda “compiler”) is found. You just have to add the -arch=sm_13 command line option where the call to nvcc is found

Many thanks - much appreciated.


I have the same problem and I’m sorry I still don’t understand what I have to do.

I use a GTX 275 and MS Visual C++ 2010 Express

I don’t call nvcc, Visual C++ 2010 Express does that for me. (Neither would I know how to call nvcc if I didn’t use Visual C++).

I’ve been searching the properties for a place where to put --gpu-name sm_13 but I didn’t find any.

I hope you can help me …



Check the properties of the project, there should be a place to add the 1.3 or find the place in the project properties where you can add flags and put the glag there.

now I’ve found where to put sm_13:

Right Click Project/Properties/Configuration/CUDA C/C++

Here “Code Generation” has to be changed from compute_10,sm_10 to compute_13,sm_13

Note that this menu is only available after a .cu-file has been created.