How to force eHCI or disable xHCI (Xavier NX)?


We are having difficulties with our USB devices, only 11 out of the 21 connected are seen with ls /dev/serial/by-id/.
These are the errors when connecting an extra USB device :

Our problem seems to be that we are exceeding some USB limits. While looking online our problem might be solved (without going with a third-party PCIe) by forcing eHCI instead of xHCI to disable USB3.0. source

I tried following this forum post, but I’m relatively new to this and I was lost.

TLDR: How do I force eHCI for the Jetson Xavier NX? And is this the solution to my problem?

Thank you!

Looks like it hits constraint of end point number. Please check
USB3 xhci driver device count limitation - #2 by DaneLLL

One possible solution is to utilize PCIe port. You may connect PCIe - USB adapter and shift some USB devices to the port.

You may also consider to use custom board. There are custom boards from our partners. Please check
Jetson Ecosystem | NVIDIA Developer

1 Like

Thank you for the info!
Secondary question then. Can the M.2 Key M socket be used for PCIe since we want to keep the wireless networking card that comes with the developer kit.

The M.2 key M slot is a PCIe interface and common device on market is NVMe SSD. Not sure if there’s PCIe to USB adapter card is designed in key M. Generally we can find PCIe to USB card in vintage PCIe slot.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.