How to get more out of Multi GPU in RTX Real-Time?

Hello there!
Some GPU testings :)

I have VM with 3 x A6000 ( not Ada )
Win 10 & Composer 2023.2.0
I am interested now in Real-time RTX.

Video is here:

See how I get only one GPU in use when I move around the scene, how could I have the other GPUs also in use here?

Then rendering in RTX Real-time.

0.18 per frame
multi GPU ON

0.22 per frame
multi GPU OFF

Why is the difference so tiny?
Looks like it is not using the power of 3 GPUS`?

On the other side, here is my Win11 & Composer 2022.3.3
with the very same A6000 GPU,
I get much better real-time framerate. The above VM with 3 GPU gave me only about 25 fps but this local setup gives me 37 fps.

1 Like

Hi Pekka,
These are very intersting findings, I am aware that multi-gpu performance scales poorly in progressive rendering but such difference is indeed very tiny…

I found this in documentation, but I believe the developers still have a lot of work to do to improve the multi-gpu scaling…

Thank you!

So do I still have to do this for my scene:
Multi-GPU must be enabled at startup by passing adding –/renderer/multiGpu/enabled=true to the command line.


I am actually not sure where it’s suppose to be executed, the Launcher.exe comes to my mind but I think it should be directly passed to USDComposer.exe but I have no idea where is it located

Someone from Nvidia please tell us?

FPS difference on different Composer versions is huge here.

Composer 2022.3.3
37 fps
video on above post by me

Composer 2023.2.2
22 fps

Double checked…
How come the new version is so much slower?

MGPU is disabled for most RTX Realtime modes unless you go into something extremely demanding or into 4k. The point of realtime is to run well on one video card. MGPU is enabed by default for iray accurate and pathtracing.

I cannot speak to why the scene is much slower in the latest version. It may be subtle differences in rendering settings, like the new denoiser mode or the DLSS performace setting. Make sure it is set to Performance.

However one big factor is comparing is that in 2022.3.3 you have the rtx window set to “1711x745” and in the latest 2023.2.0 you have the window set to “1920x1080”. So you need to do a test again with the same resolution.

1 Like

Ok, thanks Richard now we now.

Then I really need to get that AWS Activate team allow me to use my Nvidia Inception Program credits, I should be able to use desktop 4090 there.

Also we need to bring in some desktop 4090 in Infinite Compute VM stack.
My new Lenovo Mobile 4090 is about 50% slower than the 4090 Desktop model…

I make new tests, following your notes.

There is not a massive difference between the 4090 and the Ada A6000. Faster yes, but not by that much.

1 Like

What is your end goal here ? To render out this scene to disk ? Even on one A6000, this scene will render extremely quickly in rtx realtime. Well below a frame a second. Are you looking for something more ? If you need more speed than that for production reasons, simply render out of multiple single card A6000 machines and break up the animation.

1 Like

End goal is just normal Omniverse RTX realtime use.
And in the end to render out 4K 60fps realtime RTX animations, like the one you have seen on other topic already.

Reason I test these is when I add the 96 individual walking characters on the street, we need that extra GPU force. But now as I tested the “Performance” on DLLS it solved the thing! Hurray Nvidia!!! Thank you Richard!

So even multi-GPU is not easily available, the “Performance” on DLLS solved this scene, and I am not going to drop sop much new elements here – heh Except the high quality CC4 avatars, talking and moving…

About Composer 2023.2.0 ver 2022.3.3,
I still get much lower framerates with 2023.2.0 like only 18 fps compared to the 25 seen in above video…

1 Like

@Richard3D here is a video of the same project with same settings :

2023.2.0 is about 15 fps

2022.3.3 is about 19 fps

Nice one Pekka! Amazing to see all these animations working smoothly in real time! btw may I ask you where are you getting the people from?

1 Like

You should really be turning this option OFF to get true pixel to pixel test comparisons. I see you are trying to adjust the viewport manually. Just turn this option off and you are getting true 1080p or 720p

1 Like

@karol.osinski Thanks Karol!
these are from the Pedestrian Actions add-on / iClone8
I am about to finnish the huge Official Reallusion tutorial project this week, where I show step by step how to do this all!

@Richard3D You are absolutely right, this is a bad habbit of mine from the days when that fill viewport really gave better fps, but it might have been already then my misunderstanding, it actually scaled down the res while in fill viewport mode.
But now I can work in 720p in 25 fps with all these people walking - all is good here!

I have to make one more comparison screen capt with that fill viewport OFF.

1 Like

Lovely stuff! looking forward to see it!


I made a new comparison video:

The difference is huge.
Do you want me to send this scene for someone at Nvidia to check why? Or if you have some ideas / questions about the projects other settings, I am happy to share them.

Yes you can private message me with a link if you want. I see there is a drop from around 28fps to 18fps. Not good. Two things to try. 1) hide all the people for both and lets see the raw numbers for a static scene. 2) Because it is a static scene move around with the playbutton disabled.
This will compare the two versions without a 3rd party animation playing and just raw geo and lighting.

1 Like

@Richard3D I just updated my driver to 537.7 Studio Driver and see the huge different in quality & framerate when I switch the new de-noiser ON !!

I really do not need to do this comparison anymore, I already un-installed the 2022.3.3.

Also I seek for 4090 or Ada A6000 VM access, so this multi-gpu for Realtime RTX is not needed for now. Thanks!

1 Like

This is great news !!