how to get video stream from imx185-mipi(leopard)?

it is work to use nvgstcapture-1.0 to get video stream from the Original camera board,

then , use imx185-mipi(leopard) replace the Original camera board,

do nvgstcapture-1.0 ,it report Message :


Inside NvxLiteH264DecoderLowLatencyInitNvxLiteH264DecoderLowLatencyInit set DPB and MjstreamingInside NvxLiteH265DecoderLowLatencyInitNvxLiteH265DecoderLowLatencyInit set DPB and MjstreamingSocket read error. Camera Daemon stopped functioning…
gst_nvcamera_open() failed ret=0

** (nvgstcapture-1.0:7743): CRITICAL **: <create_capture_pipeline:4407> can’t set camera to playing

** (nvgstcapture-1.0:7743): CRITICAL **: main:5195 Capture Pipeline creation failed
** Message: main:5202 Capture completed
** Message: main:5252 Camera application will now exit


p.s.:where is the document about libargus ?

Hi,

Did you configure the sensor within the device tree file for the board? I think the driver comes already enabled by default in the kernel configuration however it would be good to check.

Also what does your boot log (or dmesg) output says in regards to the driver? Is it correctly registered?

In regards to libargus documentation you can find some into the tegra_multimedia_api package that is downloaded into the jetpack_download directory.

Regards,

Thank you very much!

  1. put the Original camera board,tree /dev/ > 1.txt
  2. remove the Original camera board,tree /dev/ >2.txt
  3. put the imx185-mipi(leopard),tree /dev/ >3.txt

diff 1.txt 2.txt ;add /dev/video0

diff 2.txt 3.txt ; add nothing video device

Hi,

Can you run dmesg command on your TX1 and post it here? There you should be able to see the sensor being registered if the driver/device tree were set correctly.

Regards,

File uploads only work after you post…basically you can look at the upper right corner of your post and there are some icons, one for edit (looks like a pencil), one attaches files (looks like a paper clip). Not all file types are accepted, but most logs like you have can be “.txt” extension. You can also surround your existing log text with the code quote icon ("</>" symbol) and it’ll get scroll bars if it is too long.

You can also use pastebin to share logs: http://pastebin.com/

Regards

Now, in regards to your dmesg log, there is not any entry about the imx185 sensor being registered in the system. You should see something like:

...
imx185 7-001a: [IMX185]: probing v4l2 sensor at addr 0x1a.
...

So just 3 possible error sources came to my mind:

  1. A hardware connection problem.

  2. The imx185 driver is not enabled on your kernel.

  3. Your device tree does not contain any reference to the imx185 device.

Regards,

Thanks a lot

i have ask Nvidia Official staff,they said “The default driver about imx185 is not completed.”

thanks a lot

Already done!Don’t forget a adapter board for camera module。

this is leopard team. we have the driver support 3 imx185 on tx2. you can ask simon for driver if you want.

We have IMX185 TX2 driver for our own carrier board. This driver support 3 cameras. You can get the driver from below setup guide.
https://www.dropbox.com/s/f76hdi9u8kxed78/IMX185_R28.1_TX2_CB_20170919.txt?dl=0

For Nvidia Jetson TX2 DevKit, the default driver of Jetpack 3.1 (or R28.1) support our IMX185 camera directly, but it only support one camera. We are working on the driver for multiple IMX185 cameras.