how to programming on px 2

hi,im new here for drive px 2

I did flash the px 2 broad by using SDK Manager,

I really confused that how to programming on it, should I install some environment?

what should i do after flash the broad, and how could I connect px 2 with hosts computer…

Hi hanbinl,

You can visit the TRAINING page to get more understanding: https://developer.nvidia.com/drive/learn
Even that’s for DRIVE AGX Xavier, but concept is the same.

And you can still find relevant DRIVE PX2 documents from here: https://developer.nvidia.com/drive/documentation-other

Thanks

hi kayccc,

thanks for your help, also i want to ask a question that i cant use nvcc -v to find cuda after i use SDK manager install on my host computer.

thanks

Dear hanbinl,
Please try including CUDA bin(/usr/local/cuda/bin) directory in PATH.

hi kayccc,

i add into the path, but still not work. also i cant find nvcc file, and if i use nvcc -v, it shows “the program’nvcc’ is currently not installed…”

should i reinstall cuda?

thanks

Dear hanbinl,
Could you please check installing via SDK Manager again(https://developer.nvidia.com/DRIVE/secure/files/sdkmanager-0.9.9.2351). Also, please check the ~/nvsdkm/logs folder and ~/nvsdkm/sdkm.log to confirm the status of installation. After the installation is successful, you can notice /usr/local/cuda-9.2/bin/ folder which contains nvcc.

hello SivaRamaKrishna,

i did check the sdk manager, and it shows install successful. also, i check the logs, i saw some errors but still install accomplished. Also, I found the nvcc file in cuda-9.2 folder. i still dont know in which way to fix it.

thanks a lot
hanbin

Dear hanbinl,

-. Please open ~/.bashrc file and add below the path and run source ~/.bashrc.

  1. vi ~/.bashrc and add below paths.

export PATH=/usr/local/cuda-9.2/bin/:$PATH
export LD_LIBRARY_PATH=/usr/local/cuda/targets/aarch64-linux/lib:$LD_LIBRARY_PATH

  1. source ~/.bashrc

  2. nvcc --version

hi steveNV,

thanks for help, and i got the nvcc version info after that, but when i type nvcc -v by using root usr, its still shows “The program ‘nvcc’ is currently not installed. You can install it by typing:
apt install nvidia-cuda-toolkit.” is that matter or not …

thanks
hanbin

Hi hanbinl,
Note that nvcc path should be added to $PATH variable of user. Please check echo $PATH. If you don’t find /usr/local/cuda-9.2/bin in it, update the PATH variable for root(user environment) as Steve suggested

hi sivaramakrishna,

its shows:

/usr/local/cuda-9.2/bin/:/home/hanbinli/bin:/home/hanbinli/.local/bin:/usr/local/cuda/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin

is that right…

thanks…

I assume you have logged in as root user(not with sudo command) and checked the PATH variable. In that case, It is expected to work. If you are using sudo, you need to pass ENV variable as parameter like https://stackoverflow.com/questions/8633461/how-to-keep-environment-variables-when-using-sudo