How to setup VC++2005 forCUDA the program compiled but the linker not cooperating :)

hi,
I had followed an excellent tutorial on setting up VC++2005 Express to run CUDA code, however it worked till the compile part, the Linker keeps saying that Cudart.lib and Cuda32.lib files aremissing. please help me with that one.

http://llpanorama.wordpress.com/2008/05/21…t-cuda-program/

It gave me a linker error
LINK : fatal error LNK1181: cannot open input file ‘cudart.lib’

you just set

[codebox]Configuration Properties → Linker → Input:

Additional Dependencies = cudart.lib cutil32.lib[/codebox]

you should use absolute path such as

C:\CUDA\lib64\cudart.lib

or specified PATH for linking, say

Additional library directories = C:\CUDA\lib64

above is for 64-bit, for 32-bit, use C:\CUDA\lib instead.

as for cutil32.lib, it locates at

C:\Documents and Settings\All Users\Application Data\NVIDIA Corporation\NVIDIA CUDA SDK\C\common\lib

(for cuda 2.3)

so you can use absolute path

C:\Documents and Settings\All Users\Application Data\NVIDIA Corporation\NVIDIA CUDA SDK\C\common\lib\cutil64.lib

(fro 64-bit)

finally, check your environment variable "PATH’, which should contains

C:\CUDA\bin64 (64-bit) or

C:\CUDA\bin (32-bit) and

C:\Documents and Settings\All Users\Application Data\NVIDIA

Corporation\NVIDIA CUDA SDK\C\common\lib

or program cannot find DLL support

I’m using CUDA 2.2, my card does not support the CUDA 2.3 driver. its a GeForce 8600, i think 4 SM , 32 SP. type CUDA enabled.

I just made an attachment of my log file,

I was able to locate cudart.lib and cutil32D.lib in the following folders respectively.

C:\CUDA\lib\cudart.lib

C:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\Common\lib\cutil32D.lib

i log into my windows vista after entering the username and password though i am the administrator, does that kind of logging in affect the path.
BuildLog.htm (4.59 KB)

I did the following and it compiled just fine.
Tools ->options

in the options window
select
Project and Solutions
choose
VC++ Directories
click on new line icon
manually locate and add cudart.lib and cutil32.lib.
Once those paths are included
The program builds and runs just fine