How to view and modify the CPU frequency of BlueField2


I have a BlueField-2 SmartNIC, model MBF2H516A-CEEOT. I saw from this webpage that the SoC processor can reach up to 2.75GHZ:

I tried to use sudo cpufreq-info to view the CPU’s working frequency, but it didn’t work. The display is as follows:

analyzing CPU 0:
no or unknown cpufreq driver is active on this CPU
maximum transition latency: 4294.55 ms.

How can I view the frequency of the SoC on BF2 and modify it to 2.75GHZ?

Looking forward to your reply.

Hi ,

You can use

  • lscpu

  • cpumonitor



I tried ‘lscpu’ but There is no informantion relative to frequency .here is output:

ubuntu@localhost:~$ lscpu
Architecture: aarch64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 8
On-line CPU(s) list: 0-7
Vendor ID: ARM
Model name: Cortex-A72
Model: 0
Thread(s) per core: 1
Core(s) per socket: 8
Socket(s): 1
Stepping: r1p0
BogoMIPS: 400.00
Flags: fp asimd evtstrm aes pmull sha1 sha2 crc32 cpuid
Caches (sum of all):
L1d: 256 KiB (8 instances)
L1i: 384 KiB (8 instances)
L2: 4 MiB (4 instances)
L3: 6 MiB (1 instance)
NUMA node(s): 1
NUMA node0 CPU(s): 0-7
Itlb multihit: Not affected
L1tf: Not affected
Mds: Not affected
Meltdown: Not affected
Mmio stale data: Not affected
Retbleed: Not affected
Spec store bypass: Not affected
Spectre v1: Mitigation; __user pointer sanitization
Spectre v2: Mitigation; CSV2, BHB
Srbds: Not affected
Tsx async abort: Not affected

I tried cpufreq-info and cat /proc/cpuinfo but non of this worked.

I also downloaded cpupower on BF2,here is frequecy result:

ubuntu@localhost:~$ sudo cpupower -c all frequency-info
analyzing CPU 0:
no or unknown cpufreq driver is active on this CPU
CPUs which run at the same hardware frequency: Not Available
CPUs which need to have their frequency coordinated by software: Not Available
maximum transition latency: Cannot determine or is not supported.
Not Available
available cpufreq governors: Not Available
Unable to determine current policy
current CPU frequency: Unable to call hardware
current CPU frequency: Unable to call to kernel

cpufrequtils also doesn’t work.Can you help me with this?


I use dpdk interface “rte_get_timer_cycles” get the cycles of arm core in my dpu (which is different type from yours), the values is 200,000,000 = 200Mhz , there must be somethings wrong with the interface , it’s impossible! I thinks the reasonable/reality values should be 2Ghz, beacae the “BogoMIPS: 400.00” , the two attributes could convert from each other!

‘rte_get_timer_cycles’ in my BF-2 also return 200MHz.

BogoMIPS seems to be proportional to frequency for the same processor.
On my other ubuntu machine with an intel processor, the bogoMIPS is 4200MHZ which is even higher than CPU freq 1200MHZ.

but I don’t know the ratio for this chip.

Most importantly, I want to set the frequency to 2.75GHZ(the highest frequency), but don’t know how to set it.

maybe you should enter BIOS menu when start the dpu to set the frequency! By the way , i wonder why do you want to set frequency to 2.75GHZ, the arms core’s main role is to act as control plane , the data plane’s function should offload as much as possible.

I agree with you.But getting higher CPU performance doesn’t hurt,may be possible to reduce some software stack overhead.

Please run “bfcpu-freq”


Thanks .This command line worked.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.