I can not link nvidia.box to go on pytorch, how to do?

when i operate pytorch on NX as nvidia instructions, but can not link to nvidia.box,
how can i do now?



Do you have network connection on your NX?

i worked on NX 5 days and night to try to deloyment our own yolo3 model which trained well.
our project is very urgent to use NV box as a AI platform as edge unit, and i have one few dyas to finish all to show.
i got correct pytorch whl already from a friend in USA and it works now.
but when i load darknet, and modify GPU=1, CUDNN=1, CUDA=1, it can not make. seems it is problem of opencv.
i uses jetpack 4.5.1, and opentv dpkg is 4.1.1.
pls help a link how to fix that?

many thanks!

Hi @wilicyy, see here for @mdegans script to build OpenCV with CUDA+cuDNN enabled:

i done your script, and updated cudnn patch, and changed makefile, but it shows much error again…
how can i do now?


After searching it, it seems that darknet doesn’t compile with newer version of OpenCV:

There are some patches for darknet included in those GitHub bug links. Or you can build an older version of OpenCV (I’m not sure which version darknet requires)


You can find the OpenCV & cuDNN v8.0 patch for pjreddie darknet source below:


many thanks for your supports,
and i think opencv is not urgent for my project right now, so i am trying to close opencv and go on next step.
cudnn seems ok.
i will update for new problmes.

thanks a lots!