Imgaug on Jetson Nano

Hello, I would like yo know if there is any way of installing imgaug library on Jetson nano.

pip3 install imgaug

Is (obviously) not working.
I got this error:

ERROR: Could not find a version that satisfies the requirement opencv-python (from imgaug) (from versions: none)
ERROR: No matching distribution found for opencv-python (from imgaug)

But cv2 is already installed.
Thank you.

I have the same problem X-(.

Same problem here. Opencv was installed from

make install

when I built it. I think that’s the reason why pip can’t find it. What I tried to do was to trick pip into thinking that opencv-python is installed by creating a directory named opencv_python-x.x.x.xx.dist-info and a METADATA file within. opencv-python is now listed when using

pip freeze

, but imgaug still gives the same error as OP…

Hello.

The problem is that there is no opencv-python (and opencv-python-headless) wheel for ARM on PyPI.
The document says that
“Note that the wheel (especially manylinux) format does not currently support properly ARM architecture so there are no packages for ARM based platforms in PyPI.”
ref: https://github.com/skvark/opencv-python#frequently-asked-questions

So you should build opencv-python youself.

  1. Clone opencv-python repository.
git clone https://github.com/skvark/opencv-python.git
  1. Build opencv-python.
sudo python3 setup.py install
  1. (Optional) Install qt4 SDK if needed
    Install qt4 SDK if an error is occured like ‘Could not found Qt4’.
sudo apt-get install qt4-default
  1. Install opencv-python-headless
    Edit setup.py to build opencv-python-headless.
build_headless = get_build_env_var_by_name("headless")

to

build_headless = True

After that, install opencv-python-headless.

sudo python3 setup.py install
  1. Install imgaug.
pip3 install imgaug

These works for me.

In step 2, when I run:

sudo python3 setup.py install

I get a:

ModuleNotFoundError: No module named 'pip._internal'

How did you get around this?

Thank you for your answer.

Sorry but step 2 and step 4.3 are the same, the process doesn’t work.
Any idea out there?

Thank you.

For me installing opencv-python from https://github.com/skvark/opencv-python.git worked. I installed it with

build_contrib=False #get_build_env_var_by_name("contrib")
and
build_headless=False #get_build_env_var_by_name("headless")

(from memory, code may not look exactly the same)

I think this is necessary, because otherwise the module will be called opencv-python-contrib or opencv-python-headless, but imaug is looking for exactly opencv-python.
Installing imaug then worked.

I’ve done this but the error still persists.

If you install pip (version 19) it works. The setup takes several hours though.

I uninstalled libopencv package which is coming by default with OS image because imgaug does not detect it.

Then I tried installing as you mentioned.

  1. Cloned the repository
  2. cd into opencv-python
  3. run pip3 wheel . --verbose
    This fails at a point, giving an error with the Cmake installation.

Please help!

Hi

Please help to open a new topic for your issue. Thanks