Installing OpenCv Headless

Description

I am trying to download opencv and albumentations. I followed the steps in this link: Imgaug on Jetson Nano

However this does not. I downgraded pip to version 19, changed setup.py, and it continues to return errors.
I also tried to the same process with pip version 20, and it returns even more errors.

Environment

I have one jetson nano.
TensorRT Version:
GPU Type:
Nvidia Driver Version:
CUDA Version:
CUDNN Version:
Operating System + Version:
Python Version (if applicable):
TensorFlow Version (if applicable):
PyTorch Version (if applicable):
Baremetal or Container (if container which image + tag):

Relevant Files

Please attach or include links to any models, data, files, or scripts necessary to reproduce your issue. (Github repo, Google Drive, Dropbox, etc.)

Steps To Reproduce

Please include:

  • Exact steps/commands to build your repro
  • Exact steps/commands to run your repro
  • Full traceback of errors encountered

Hi @nagarwal2004
Moving this to Jetson Nano Team for better assistance.
Thanks!

Hi,

Not very sure about what you want to do. If you just want to install opencv, then build it from source or use the one we provided in sdkmanager should both work.

I need to install open cv headless for libraries such as imguag and albumentations. The one provided by sdkmanager does not contain open cv headless.
I then tried building it from source and it returns an error with pip. I have tried everything with pip including downgrading and upgrading it.

Hi,

Sorry no we have no experience with opencv headless. Maybe you could file a topic on openCV forum too.
Or wait for other users here to share.

Why not install all the package in jetpack? We need these package to form our pytorch model by TensorRT