Install NVIDIA driver with Tesla K40m

Hi, I’m trying to install a Tesla K40m on my Ubuntu 20.04 workstation but it is driving me crazy. I am using the HDMI port on the motherboard for graphics and want to just use the Tesla card for getting up to speed on CUDA programming and machine learning applications. No matter what I try, when I run nvidia-smi I get “no device found.”

I’ve followed the installation guide and successfully installed the 470 drivers using the software & update GUI (although I have tried both the .deb and .run installs as well). I’ve
made sure to blacklist the nouveau driver:

cat /etc/modprobe.d/blacklist.conf | grep nouveau

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off

I’ve gone into the Bios and enabled “above 4G encoding” and disabled secure boot.

I can see the error in the bug report:

Jul 25 06:39:08 armordillo kernel: [    4.597445] [drm] [nvidia-drm] [GPU ID 0x00000600] Loading driver
Jul 25 06:39:08 armordillo kernel: [    4.597447] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:06:00.0 on minor 1
Jul 25 06:39:08 armordillo kernel: [    4.622148] nvidia-uvm: Loaded the UVM driver, major device number 234.
Jul 25 06:39:11 armordillo kernel: [    8.600127] NVRM: GPU 0000:06:00.0: RmInitAdapter failed! (0x22:0xffff:667)
Jul 25 06:39:11 armordillo kernel: [    8.600147] NVRM: GPU 0000:06:00.0: rm_init_adapter failed, device minor number 0

I have just reached the end of my knowledge of how to get past that. Any help or suggestions are appreciated.

nvidia-bug-report.log.gz (131.1 KB)