Install pytorch1.7 with python 3.8

Hey everyone! I have a Jetson Nano developer board:

 - Jetpack:        UNKNOWN [L4T 32.7.4]                                                   
 - Board:                                                                                 
   * Type:           Nano (Developer Kit Version)
   * SOC Family:     tegra210     ID: 33
   * Module:         P3448-0000   Board: P3449-0000
   * Code Name:      porg
   * Cuda ARCH:      5.3
   * Serial Number:  1420121016413
   * Board ids:      3448
 - Libraries:                                                                         
   * CUDA:         10.2.300                                                           
   * OpenCV:       4.6.0  compiled CUDA: YES                                            
   * TensorRT:                                                       
   * VPI:          ii libnvvpi1 1.2.3 arm64 NVIDIA Vision Programming Interface library
   * VisionWorks:
   * Vulkan:       1.2.70
   * cuDNN:

I need to install ultralytics (yolov8), so python3.8 and pytorch 1.7 are required (at least). I’ve installed python3.8 with sudo apt install python3.8 and addded to .bashrc:

alias python3='python3.8'
alias pip3='python3.8 -m pip'

Next I tried to build pytorch from source, but got errors. May I get an instruction here how to install pytorch1.7, torchvision 0.8, ultralytics?

If it is needed, I can also share how I tried to build pytorch and what problems I saw (it was build but I could not import pytorch because something like this: OSError: /home/argo/pytorch/torch/lib/ cannot open shared object file: No such file or directory)


We don’t have a PyTorch package for Python 3.8 on Nano.
Please build it from the source.

You can find the instructions below:


Thanks for the instructions, I will look into it. Also, may I know, do you have any plans on updating low end hardware like jetson nano? Orin nano is too expensive, it would be great to get a new affordable nano. The problem is not even in the hardware side, but support.


We provide a package for the default Python version.
For Ubuntu 18.04 used by Nano, it’s Python 3.6.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.