Install tty acm module on Jetson Xavier

I tried to install tty acm module (driver) on Xavier with no success (as it is not automatically installed; see the log of /dev/tty device below). I have found a method to install it on Jetsonhack website, but it works only for tx1 and tx2. Could you please help me in installing this module?

[Created at usb.122]
Unique ID: Q3sC.1KovF6zT2I7
Parent ID: k4bc.+N3vcF8QTi8
SysFS ID: /devices/3610000.xhci/usb1/1-2/1-2:1.4
SysFS BusID: 1-2:1.4
Hardware Class: modem
Model: “DJI”
Hotplug: USB
Vendor: usb 0x2ca3 “DJI”
Device: usb 0x001f “DJI”
Revision: “ff.ff”
Serial ID: “0123456789ABCDEF”
Device File: /dev/ttyACM0
Speed: 480 Mbps
Module Alias: “usb:v2CA3p001FdFFFFdc00dsc00dp00ic02isc02ip01in04”
Driver Info #0:
Driver Status: cdc_acm is not active
Driver Activation Cmd: “modprobe cdc_acm”
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #29 (Hub)

Kernel module compile and install are the same on all Jetson platforms from ancient days through Xavier and Nano.

In the end the new kernel module file is just an ordinary copy followed by “sudo depmod -a” and reboot (or “sudo modprobe cdc_acm”). So probably a copy goes to:

/lib/modules/$(uname -r)/kernel/drivers/usb/class/cdc-acm.ko

If you have questions from the other instructions just ask. If you’ve flashed before you will have directory “Linux_for_Tegra/” on your host PC, and within that “source_sync.sh”. You can get the correct kernel source for a given release using that, and for example, for R31.1:

./source_sync.sh -k tegra-l4t-r31.1

(I haven’t tried this yet for R32.1 but just drop a note here on the forums if you have issue…source is also available in the official R32.1 downloads)