Installed CUDA 9.1 on Ubuntu 17010 but nvidia-smi does not show anything and freezes


I have installed the latest NVIDIA driver (390.46) and the latest CUDA 9.1.85 on my Ubuntu 17.10 server with 4 Tesla K80 GPUs. Now when running nvidia-smi, it does not show anything, and I have to press Ctrl+C to stop it. When running nvcc -V it says: The program ‘nvcc’ is currently not installed.

The kernel version of the server: 4.13.0-38-generic.

Thank you very much in advance for your help!

Update: I tried letting nvidia-smi running and it does show information on the GPUs after more than 1.5 minutes. I guess this is not normal. Could you please help? Thanks a lot!

When the GPUs are in use, nvidia-smi shows instantly.
Problem solved. Thank you.

you can set persistence mode (google that)

regarding this:

“When running nvcc -V it says: The program ‘nvcc’ is currently not installed.”

that’s a result of not completing the installation process correctly

read the CUDA linux install guide, especially post-install steps