Intel 12700H Gforce RTX3070 Ti on Ubuntu 22.04 kernel 5.15.0-40/41-generic and nvidia-driver 515 black screen after suspend

Hi,

I’ve been trying everything that I could find in related threads.
I am using a lenovo legion pro 5 with graphics and processor as mention in the title without any periphery.
When the system goes into suspend by (1) either closing the laptop or (2) through systemctl and then try to wake it up again by opening the lid and pressing any button. The screen stays black (no backlight) and after some time 1-2 minutes the fan kicks in heavily until the system shuts off.

I will attach the bug-report.sh.
dmseg says :

[   19.965216] snapd-desktop-i[2669]: segfault at 0 ip 00007f906ba66364 sp 00007ffee9304ac8 error 4 in libglib-2.0.so.0.6400.6[7f906ba3c000+9a000]
[   19.965225] Code: f8 5b 5d c3 66 90 f3 0f 1e fa 48 83 ec 08 e8 c3 70 fd ff 85 c0 0f 94 c0 48 83 c4 08 0f b6 c0 c3 66 0f 1f 44 00 00 f3 0f 1e fa <0f> be 07 41 b8 05 15 00 00 84 c0 74 1d 0f 1f 80 00 00 00 00 44 89
[   20.034303] rfkill: input handler disabled
[   20.333600] snapd-desktop-i[2980]: segfault at 0 ip 00007f72f9b63364 sp 00007ffe7a12fef8 error 4 in libglib-2.0.so.0.6400.6[7f72f9b39000+9a000]
[   20.333613] Code: f8 5b 5d c3 66 90 f3 0f 1e fa 48 83 ec 08 e8 c3 70 fd ff 85 c0 0f 94 c0 48 83 c4 08 0f b6 c0 c3 66 0f 1f 44 00 00 f3 0f 1e fa <0f> be 07 41 b8 05 15 00 00 84 c0 74 1d 0f 1f 80 00 00 00 00 44 89
[   21.851880] [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership
[   21.851934] [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership
[   21.851966] [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership
[   21.878686] [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership
[   21.878731] [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership
[   21.878762] [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership
[   21.902774] [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership
[   21.902842] [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership
[   21.902871] [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership

mem_sleep is:
s2idle [deep]

cat /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf

DO NOT EDIT. AUTOMATICALLY GENERATED BY gpu-manager

Section “OutputClass”
Identifier “Nvidia Prime”
MatchDriver “nvidia-drm”
Driver “nvidia”
Option “AllowEmptyInitialConfiguration”
Option “IgnoreDisplayDevices” “CRT”
Option “PrimaryGPU” “Yes”
ModulePath “/lib/x86_64-linux-gnu/nvidia/xorg”
EndSection

Any help is highly appreciated!
I have Windows 11 installed on a separate partition. No problem there.

log_file: /var/log/gpu-manager.log
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/5.15.0-40-generic/kernel
Looking for nvidia modules in /lib/modules/5.15.0-40-generic/kernel/nvidia-515srv
Looking for nvidia modules in /lib/modules/5.15.0-40-generic/kernel/nvidia-515
Found nvidia.ko module in /lib/modules/5.15.0-40-generic/kernel/nvidia-515/nvidia.ko
Looking for amdgpu modules in /lib/modules/5.15.0-40-generic/kernel
Looking for amdgpu modules in /lib/modules/5.15.0-40-generic/updates/dkms
Is nvidia loaded? yes
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? yes
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? yes
Is nvidia kernel module available? yes
Is amdgpu kernel module available? no
Vendor/Device Id: 8086:46a6
BusID "PCI:0@0:2:0"
Is boot vga? yes
Vendor/Device Id: 10de:24e0
BusID "PCI:1@0:0:0"
Is boot vga? no
Chassis type: "10"
Laptop detected
can't access /etc/u-d-c-nvidia-runtimepm-override file
Found json file: /usr/share/doc/nvidia-driver-515-server/supported-gpus.json
File /usr/share/doc/nvidia-driver-515-server/supported-gpus.json not found
Is nvidia runtime pm supported for "0x24e0"? yes
Trying to create new file: /run/nvidia_runtimepm_supported
Checking power status in /proc/driver/nvidia/gpus/0000:01:00.0/power
Runtime D3 status:          ?
Is nvidia runtime pm enabled for "0x24e0"? no
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Does it require offloading? no
last cards number = 2
Has amd? no
Has intel? yes
Has nvidia? yes
How many cards? 2
Has the system changed? No
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
can't access /run/u-d-c-nvidia-drm-was-loaded file
Takes 980ms to wait for nvidia udev rules completed.
Intel IGP detected
NVIDIA hybrid system
Creating /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf
Setting power control to "on" in /sys/bus/pci/devices/0000:01:00.0/power/control

Processing: nvidia-bug-report.log.gz…

actually, i booted windows again, just to be sure, and closed the laptop over night. Next morning same thing happend even under windows. When opening the laptop there was just a completely black screen, keyboard was lighted. No response on any keaboard/touchpad input.

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX=“”
GRUB_CMDLINE_LINUX_DEFAULT=“nvidia-drm.modeset=1 nvidia.NVreg_RegistryDwords=EnableBrightnessControl=1”

After, getting my hands on a second machine for further testing i was able to get a some more information of dmseg right after the suspend and resume which says:

[ 1783.483820] audit: type=1420 audit(1657552095.381:72): subj_apparmor=unconfined
[ 1783.596648] r8169 0000:31:00.0 enp49s0: Link is Down
[ 1786.041437] rfkill: input handler enabled
[ 1786.913191] PM: suspend entry (deep)
[ 1787.056101] Filesystems sync: 0.142 seconds
[ 1787.056707] Freezing user space processes ... (elapsed 0.001 seconds) done.
[ 1787.058660] OOM killer disabled.
[ 1787.058661] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[ 1787.059917] printk: Suspending console(s) (use no_console_suspend to debug)
[ 1787.890654] ------------[ cut here ]------------
[ 1787.890655] i915 0000:00:02.0: i915 raw-wakerefs=1 wakelocks=1 on cleanup
[ 1787.890674] WARNING: CPU: 0 PID: 7194 at drivers/gpu/drm/i915/intel_runtime_pm.c:635 intel_runtime_pm_driver_release+0x4e/0x60 [i915]
[ 1787.890717] Modules linked in: tls nfnetlink rfcomm snd_hda_codec_realtek snd_hda_codec_generic cmac algif_hash algif_skcipher af_alg nvidia_uvm(POE) bnep uvcvideo btusb btrtl videobuf2_vmalloc btbcm btintel videobuf2_memops videobuf2_v4l2 bluetooth videobuf2_common videodev mc ecdh_generic ecc usbhid nvidia_drm(POE) intel_tcc_cooling nvidia_modeset(POE) x86_pkg_temp_thermal intel_powerclamp snd_sof_pci_intel_tgl snd_sof_intel_hda_common soundwire_intel soundwire_generic_allocation soundwire_cadence snd_sof_intel_hda snd_sof_pci coretemp snd_sof_xtensa_dsp snd_sof snd_soc_hdac_hda snd_hda_ext_core snd_soc_acpi_intel_match iwlmvm snd_soc_acpi soundwire_bus ledtrig_audio snd_soc_core mac80211 snd_compress snd_hda_codec_hdmi ac97_bus snd_pcm_dmaengine nvidia(POE) kvm_intel snd_hda_intel libarc4 i915 snd_intel_dspcfg kvm snd_seq_midi snd_intel_sdw_acpi joydev snd_seq_midi_event crct10dif_pclmul ghash_clmulni_intel snd_rawmidi snd_hda_codec aesni_intel ttm snd_hda_core crypto_simd cryptd
[ 1787.890737]  nls_iso8859_1 rapl iwlwifi drm_kms_helper snd_seq mei_hdcp snd_hwdep input_leds processor_thermal_device_pci intel_rapl_msr intel_cstate serio_raw nvidia_wmi_ec_backlight wmi_bmof snd_pcm hid_multitouch snd_seq_device cec processor_thermal_device snd_timer mei_me rc_core processor_thermal_rfim cfg80211 i2c_algo_bit mei snd fb_sys_fops processor_thermal_mbox syscopyarea processor_thermal_rapl sysfillrect pmt_telemetry ucsi_acpi soundcore sysimgblt intel_rapl_common pmt_class typec_ucsi igen6_edac typec ideapad_laptop sparse_keymap int3403_thermal platform_profile int340x_thermal_zone int3400_thermal acpi_thermal_rel acpi_tad acpi_pad mac_hid sch_fq_codel ipmi_devintf ipmi_msghandler msr parport_pc ppdev lp ramoops pstore_blk parport reed_solomon pstore_zone mtd efi_pstore drm ip_tables x_tables autofs4 hid_generic intel_lpss_pci i2c_hid_acpi i2c_hid nvme crc32_pclmul intel_lpss r8169 i2c_i801 xhci_pci thunderbolt i2c_smbus realtek nvme_core idma64 xhci_pci_renesas intel_pmt
[ 1787.890762]  hid wmi video pinctrl_tigerlake
[ 1787.890763] CPU: 0 PID: 7194 Comm: kworker/u40:11 Tainted: P        W  OE     5.15.0-40-generic #43-Ubuntu
[ 1787.890765] Hardware name: LENOVO 82RF/LNVNB161216, BIOS J2CN32WW 01/24/2022
[ 1787.890766] Workqueue: events_unbound async_run_entry_fn
[ 1787.890770] RIP: 0010:intel_runtime_pm_driver_release+0x4e/0x60 [i915]
[ 1787.890796] Code: 10 4c 8b 6f 50 4d 85 ed 75 03 4c 8b 2f e8 aa 16 63 dc 41 89 d8 44 89 e1 4c 89 ea 48 89 c6 48 c7 c7 38 6d 5d c2 e8 39 09 aa dc <0f> 0b 5b 41 5c 41 5d 5d c3 66 0f 1f 84 00 00 00 00 00 0f 1f 44 00
[ 1787.890797] RSP: 0018:ffffb9ab42543d20 EFLAGS: 00010282
[ 1787.890798] RAX: 0000000000000000 RBX: 0000000000000001 RCX: 0000000000000027
[ 1787.890799] RDX: ffff967fdf620588 RSI: 0000000000000001 RDI: ffff967fdf620580
[ 1787.890799] RBP: ffffb9ab42543d38 R08: 000000000000003d R09: 0000000000000001
[ 1787.890800] R10: 0000000000ffff0a R11: 0000000000000001 R12: 0000000000000001
[ 1787.890800] R13: ffff967c42e59ca0 R14: ffff967c47586bb0 R15: ffffffff9f87aa94
[ 1787.890801] FS:  0000000000000000(0000) GS:ffff967fdf600000(0000) knlGS:0000000000000000
[ 1787.890802] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 1787.890802] CR2: 000056452277a4e6 CR3: 00000002cdc10003 CR4: 0000000000770ef0
[ 1787.890803] PKRU: 55555554
[ 1787.890803] Call Trace:
[ 1787.890804]  <TASK>
[ 1787.890806]  i915_drm_suspend_late+0xf2/0x110 [i915]
[ 1787.890828]  ? pci_pm_poweroff_late+0x40/0x40
[ 1787.890831]  i915_pm_suspend_late+0x1d/0x30 [i915]
[ 1787.890852]  pm_generic_suspend_late+0x28/0x30
[ 1787.890854]  pci_pm_suspend_late+0x37/0x40
[ 1787.890855]  dpm_run_callback+0x69/0x120
[ 1787.890856]  __device_suspend_late+0xc3/0x260
[ 1787.890858]  async_suspend_late+0x23/0x60
[ 1787.890859]  async_run_entry_fn+0x30/0x120
[ 1787.890860]  process_one_work+0x228/0x3d0
[ 1787.890862]  worker_thread+0x53/0x410
[ 1787.890863]  ? process_one_work+0x3d0/0x3d0
[ 1787.890864]  kthread+0x127/0x150
[ 1787.890866]  ? set_kthread_struct+0x50/0x50
[ 1787.890867]  ret_from_fork+0x1f/0x30
[ 1787.890869]  </TASK>
[ 1787.890870] ---[ end trace 0c80126b6dff10bb ]---
[ 1787.914611] ACPI: EC: interrupt blocked
[ 1788.041478] ACPI: PM: Preparing to enter system sleep state S3
[ 1788.052021] ACPI: EC: event blocked
[ 1788.052022] ACPI: EC: EC stopped
[ 1788.052022] ACPI: PM: Saving platform NVS memory
[ 1788.052211] Disabling non-boot CPUs ...
[ 1788.056167] smpboot: CPU 1 is now offline
[ 1788.058324] smpboot: CPU 2 is now offline
[ 1788.062134] smpboot: CPU 3 is now offline
[ 1788.063974] smpboot: CPU 4 is now offline
[ 1788.067158] smpboot: CPU 5 is now offline
[ 1788.068912] smpboot: CPU 6 is now offline
[ 1788.072193] smpboot: CPU 7 is now offline
[ 1788.073933] smpboot: CPU 8 is now offline
[ 1788.077197] smpboot: CPU 9 is now offline
[ 1788.080390] smpboot: CPU 10 is now offline
[ 1788.082172] smpboot: CPU 11 is now offline
[ 1788.083866] smpboot: CPU 12 is now offline
[ 1788.085649] smpboot: CPU 13 is now offline
[ 1788.087373] smpboot: CPU 14 is now offline
[ 1788.089200] smpboot: CPU 15 is now offline
[ 1788.090986] smpboot: CPU 16 is now offline
[ 1788.092642] smpboot: CPU 17 is now offline
[ 1788.094251] smpboot: CPU 18 is now offline
[ 1788.096221] smpboot: CPU 19 is now offline
[18446744065.366365] [Firmware Bug]: TSC ADJUST differs: CPU0 0 --> -707176430. Restoring
[ 1788.103698] ACPI: PM: Low-level resume complete
[ 1788.103761] ACPI: EC: EC started
[ 1788.103762] ACPI: PM: Restoring platform NVS memory
[ 1788.109496] Enabling non-boot CPUs ...
[ 1788.109530] x86: Booting SMP configuration:
[ 1788.109531] smpboot: Booting Node 0 Processor 1 APIC 0x1
[ 1788.111730] CPU1 is up
[ 1788.111754] smpboot: Booting Node 0 Processor 2 APIC 0x8
[ 1788.120696] CPU2 is up
[ 1788.120717] smpboot: Booting Node 0 Processor 3 APIC 0x9
[ 1788.122863] CPU3 is up
[ 1788.122881] smpboot: Booting Node 0 Processor 4 APIC 0x10
[ 1788.130413] CPU4 is up
[ 1788.130432] smpboot: Booting Node 0 Processor 5 APIC 0x11
[ 1788.132790] CPU5 is up
[ 1788.132807] smpboot: Booting Node 0 Processor 6 APIC 0x18
[ 1788.140305] CPU6 is up
[ 1788.140369] smpboot: Booting Node 0 Processor 7 APIC 0x19
[ 1788.143066] CPU7 is up
[ 1788.143110] smpboot: Booting Node 0 Processor 8 APIC 0x20
[ 1788.154969] CPU8 is up
[ 1788.155021] smpboot: Booting Node 0 Processor 9 APIC 0x21
[ 1788.157829] CPU9 is up
[ 1788.157879] smpboot: Booting Node 0 Processor 10 APIC 0x28
[ 1788.170715] CPU10 is up
[ 1788.170763] smpboot: Booting Node 0 Processor 11 APIC 0x29
[ 1788.174063] CPU11 is up
[ 1788.174117] smpboot: Booting Node 0 Processor 12 APIC 0x30
[ 1788.183972] core: cpu_atom PMU driver: PEBS-via-PT
[ 1788.183978] ... version:                5
[ 1788.183979] ... bit width:              48
[ 1788.183981] ... generic registers:      6
[ 1788.183981] ... value mask:             0000ffffffffffff
[ 1788.183983] ... max period:             00007fffffffffff
[ 1788.183984] ... fixed-purpose events:   3
[ 1788.183984] ... event mask:             000000070000003f
[ 1788.184959] CPU12 is up
[ 1788.185012] smpboot: Booting Node 0 Processor 13 APIC 0x32
[ 1788.190829] CPU13 is up
[ 1788.190876] smpboot: Booting Node 0 Processor 14 APIC 0x34
[ 1788.196491] CPU14 is up
[ 1788.196545] smpboot: Booting Node 0 Processor 15 APIC 0x36
[ 1788.202010] CPU15 is up
[ 1788.202066] smpboot: Booting Node 0 Processor 16 APIC 0x38
[ 1788.213368] CPU16 is up
[ 1788.213417] smpboot: Booting Node 0 Processor 17 APIC 0x3a
[ 1788.219328] CPU17 is up
[ 1788.219381] smpboot: Booting Node 0 Processor 18 APIC 0x3c
[ 1788.225130] CPU18 is up
[ 1788.225181] smpboot: Booting Node 0 Processor 19 APIC 0x3e
[ 1788.230812] CPU19 is up
[ 1788.237376] ACPI: PM: Waking up from system sleep state S3
[ 1788.239672] ACPI: button: The lid device is not compliant to SW_LID.
[ 1788.239952] ACPI: EC: interrupt unblocked
[ 1788.428699] ACPI: EC: event unblocked
[ 1788.429738] xhci_hcd 0000:00:0d.0: xHC error in resume, USBSTS 0x401, Reinit
[ 1788.429741] usb usb1: root hub lost power or was reset
[ 1788.429741] usb usb2: root hub lost power or was reset
[ 1788.530970] nvme nvme0: Shutdown timeout set to 10 seconds
[ 1788.535216] nvme nvme0: 20/0/0 default/read/poll queues
[ 1788.535309] i915 0000:00:02.0: [drm] GuC firmware i915/adlp_guc_62.0.3.bin version 62.0 submission:enabled
[ 1788.535312] i915 0000:00:02.0: [drm] GuC SLPC: enabled
[ 1788.535312] i915 0000:00:02.0: [drm] HuC firmware i915/tgl_huc_7.9.3.bin version 7.9 authenticated:yes
[ 1788.535648] i915 0000:00:02.0: [drm] GuC RC: enabled
[ 1788.742728] usb 3-6: reset high-speed USB device number 4 using xhci_hcd
[ 1789.405084] i915 0000:00:02.0: [drm] *ERROR* Failed to write source OUI
[ 1794.762185] i915 0000:00:02.0: [drm] *ERROR* failed to enable link training
[ 1796.091434] i915 0000:00:02.0: [drm] *ERROR* Failed to read current backlight control mode: -110
[ 1796.111025] mei_hdcp 0000:00:16.0-b638ab7e-94e2-4ea2-a552-d1c54b627f04: bound 0000:00:02.0 (ops i915_hdcp_component_ops [i915])
[ 1796.758864] i915 0000:00:02.0: [drm] *ERROR* Failed to read DPCD register 0x60
[ 1798.086243] i915 0000:00:02.0: [drm] *ERROR* Failed to read DPCD register 0x92
[ 1801.841172] i915 0000:00:02.0: [drm] *ERROR* Failed to write source OUI
[ 1807.198235] i915 0000:00:02.0: [drm] *ERROR* failed to enable link training
[ 1808.527201] i915 0000:00:02.0: [drm] *ERROR* Failed to read current backlight control mode: -110
[ 1808.534087] OOM killer enabled.
[ 1808.534088] Restarting tasks ... done.
[ 1808.536255] thermal thermal_zone10: failed to read out thermal zone (-61)
[ 1808.638798] PM: suspend exit
[ 1809.205037] i915 0000:00:02.0: [drm] *ERROR* Failed to read DPCD register 0x60
[ 1810.199358] rfkill: input handler disabled
[ 1810.199376] audit: type=1107 audit(1657552145.091:73): pid=781 uid=102 auid=4294967295 ses=4294967295 subj=? msg='apparmor="DENIED" operation="dbus_signal"  bus="system" path="/org/freedesktop/login1" interface="org.freedesktop.login1.Manager" member="PrepareForSleep" name=":1.36" mask="receive" pid=3797 label="snap.firefox.firefox" peer_pid=811 peer_label="unconfined"
                exe="/usr/bin/dbus-daemon" sauid=102 hostname=? addr=? terminal=?'
[ 1810.199380] audit: type=1420 audit(1657552145.091:74): subj_apparmor=unconfined
[ 1810.226730] Generic FE-GE Realtek PHY r8169-0-3100:00: attached PHY driver (mii_bus:phy_addr=r8169-0-3100:00, irq=MAC)
[ 1810.439184] r8169 0000:31:00.0 enp49s0: Link is Down
[ 1810.549151] i915 0000:00:02.0: [drm] *ERROR* Failed to read DPCD register 0x92
[ 1812.548581] i915 0000:00:02.0: [drm] *ERROR* Failed to read DPCD register 0x60
[ 1813.879049] i915 0000:00:02.0: [drm] *ERROR* Failed to read DPCD register 0x92
[ 1814.100511] r8169 0000:31:00.0 enp49s0: Link is Up - 1Gbps/Full - flow control off
[ 1814.100525] IPv6: ADDRCONF(NETDEV_CHANGE): enp49s0: link becomes ready
[ 1817.178246] audit: type=1107 audit(1657552152.067:75): pid=781 uid=102 auid=4294967295 ses=4294967295 subj=? msg='apparmor="DENIED" operation="dbus_signal"  bus="system" path="/org/freedesktop/login1" interface="org.freedesktop.login1.Manager" member="SessionRemoved" name=":1.36" mask="receive" pid=3797 label="snap.firefox.firefox" peer_pid=811 peer_label="unconfined"
                exe="/usr/bin/dbus-daemon" sauid=102 hostname=? addr=? terminal=?'
[ 1817.178252] audit: type=1420 audit(1657552152.067:76): subj_apparmor=unconfined
[ 1817.681889] i915 0000:00:02.0: [drm] *ERROR* Failed to write source OUI
[ 1823.044770] i915 0000:00:02.0: [drm] *ERROR* failed to enable link training
[ 1824.374107] i915 0000:00:02.0: [drm] *ERROR* Failed to read current backlight control mode: -110
[ 1825.077647] i915 0000:00:02.0: [drm] *ERROR* Failed to read DPCD register 0x60
[ 1826.406460] i915 0000:00:02.0: [drm] *ERROR* Failed to read DPCD register 0x92
[ 1828.592231] audit: type=1107 audit(1657552163.483:77): pid=781 uid=102 auid=4294967295 ses=4294967295 subj=? msg='apparmor="DENIED" operation="dbus_signal"  bus="system" path="/org/freedesktop/login1" interface="org.freedesktop.login1.Manager" member="SessionNew" name=":1.36" mask="receive" pid=3797 label="snap.firefox.firefox" peer_pid=811 peer_label="unconfined"
                exe="/usr/bin/dbus-daemon" sauid=102 hostname=? addr=? terminal=?'
[ 1828.592236] audit: type=1420 audit(1657552163.483:78): subj_apparmor=unconfined
[ 1830.193983] i915 0000:00:02.0: [drm] *ERROR* Failed to write source OUI
[ 1835.558469] i915 0000:00:02.0: [drm] *ERROR* failed to enable link training
[ 1836.889596] i915 0000:00:02.0: [drm] *ERROR* Failed to read current backlight control mode: -110
[ 1837.605450] i915 0000:00:02.0: [drm] *ERROR* Failed to read DPCD register 0x60
[ 1838.933172] i915 0000:00:02.0: [drm] *ERROR* Failed to read DPCD register 0x92

https://gitlab.freedesktop.org/drm/intel/-/issues/4950
Seems you need to update your bios.

Thanks!
This solved the drm error.
The kernel more or less updated itself from 15.5.-40 to 5.15.0-41 at some point after the BIOS update.
Now I get ACPI BIOS Error (bug):

] r8169 0000:34:00.0 enp52s0: Link is Down
[    3.604423] i915 0000:00:02.0: [drm] failed to retrieve link info, disabling eDP
[    3.720107] i915 0000:00:02.0: [drm] GuC firmware i915/adlp_guc_62.0.3.bin version 62.0 submission:enabled
[    3.720111] i915 0000:00:02.0: [drm] GuC SLPC: enabled
[    3.720112] i915 0000:00:02.0: [drm] HuC firmware i915/tgl_huc_7.9.3.bin version 7.9 authenticated:yes
[    3.720497] i915 0000:00:02.0: [drm] GuC RC: enabled
[    3.795491] loop15: detected capacity change from 0 to 8
[    3.847980] ACPI BIOS Error (bug): Could not resolve symbol [\_TZ.ETMD], AE_NOT_FOUND (20210730/psargs-330)

[    3.847991] No Local Variables are initialized for Method [_OSC]

[    3.847992] Initialized Arguments for Method [_OSC]:  (4 arguments defined for method invocation)
[    3.847993]   Arg0:   000000008b72943f <Obj>           Buffer(16) 5D A8 3B B2 B7 C8 42 35
[    3.847999]   Arg1:   00000000484aa5cf <Obj>           Integer 0000000000000001
[    3.848002]   Arg2:   000000006cea1800 <Obj>           Integer 0000000000000002
[    3.848004]   Arg3:   00000000207053f4 <Obj>           Buffer(8) 00 00 00 00 05 00 00 00

[    3.848009] ACPI Error: Aborting method \_SB.IETM._OSC due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[    3.935208] ------------[ cut here ]------------
[    3.935210] i915 0000:00:02.0: drm_WARN_ON(intel_dp->pps.vdd_wakeref)
[    3.935232] WARNING: CPU: 16 PID: 546 at drivers/gpu/drm/i915/display/intel_pps.c:591 intel_pps_vdd_on_unlocked+0x286/0x2a0 [i915]
[    3.935329] Modules linked in: bnep btusb btrtl btbcm btintel bluetooth usbhid ecdh_generic ecc uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_common videodev mc snd_sof_pci_intel_tgl snd_sof_intel_hda_common soundwire_intel soundwire_generic_allocation soundwire_cadence snd_sof_intel_hda snd_sof_pci snd_sof_xtensa_dsp intel_tcc_cooling snd_sof x86_pkg_temp_thermal intel_powerclamp snd_soc_hdac_hda snd_hda_ext_core snd_soc_acpi_intel_match snd_soc_acpi soundwire_bus ledtrig_audio snd_soc_core snd_compress coretemp ac97_bus snd_pcm_dmaengine iwlmvm snd_hda_intel snd_intel_dspcfg joydev kvm_intel i915(+) snd_intel_sdw_acpi mac80211 kvm snd_hda_codec crct10dif_pclmul snd_seq_midi ghash_clmulni_intel snd_seq_midi_event libarc4 snd_hda_core aesni_intel snd_rawmidi crypto_simd ttm snd_hwdep cryptd rapl nls_iso8859_1 iwlwifi drm_kms_helper snd_pcm snd_seq mei_hdcp input_leds intel_rapl_msr intel_cstate serio_raw snd_seq_device cfg80211 wmi_bmof nvidia_wmi_ec_backlight cec
[    3.935359]  snd_timer mei_me hid_multitouch snd rc_core processor_thermal_device_pci mei processor_thermal_device i2c_algo_bit fb_sys_fops processor_thermal_rfim syscopyarea pmt_telemetry ucsi_acpi(+) sysfillrect soundcore processor_thermal_mbox pmt_class processor_thermal_rapl sysimgblt typec_ucsi igen6_edac intel_rapl_common typec ideapad_laptop sparse_keymap int3403_thermal platform_profile int340x_thermal_zone int3400_thermal acpi_pad acpi_thermal_rel acpi_tad mac_hid sch_fq_codel ipmi_devintf ipmi_msghandler msr parport_pc ppdev lp ramoops parport reed_solomon pstore_blk pstore_zone mtd efi_pstore drm ip_tables x_tables autofs4 hid_generic i2c_hid_acpi r8169 i2c_i801 intel_lpss_pci crc32_pclmul nvme i2c_hid intel_lpss xhci_pci thunderbolt i2c_smbus realtek nvme_core idma64 xhci_pci_renesas intel_pmt hid wmi video pinctrl_tigerlake

Which then, I think, prevents the nvidia diver from being loaded. I have uninstalled all nvidia drivers in this dmseg output.
When reinstalling nvidia-driver 515 from with gui “additional drivers” dmseg says:

[  327.892149] NVRM: No NVIDIA devices probed.
[  327.892682] nvidia-nvlink: Unregistered Nvlink Core, major device number 506
[  328.136637] nvidia-nvlink: Nvlink Core is being initialized, major device number 506
[  328.136641] NVRM: The NVIDIA probe routine was not called for 1 device(s).
[  328.137488] NVRM: This can occur when a driver such as:
               NVRM: nouveau, rivafb, nvidiafb or rivatv
               NVRM: was loaded and obtained ownership of the NVIDIA device(s).
[  328.137489] NVRM: Try unloading the conflicting kernel module (and/or
               NVRM: reconfigure your kernel without the conflicting
               NVRM: driver(s)), then try loading the NVIDIA kernel module
               NVRM: again.
[  328.137489] NVRM: No NVIDIA devices probed.
[  328.137967] nvidia-nvlink: Unregistered Nvlink Core, major device number 506
[  328.380508] nvidia-nvlink: Nvlink Core is being initialized, major device number 506
[  328.380511] NVRM: The NVIDIA probe routine was not called for 1 device(s).
[  328.381290] NVRM: This can occur when a driver such as:
               NVRM: nouveau, rivafb, nvidiafb or rivatv
               NVRM: was loaded and obtained ownership of the NVIDIA device(s).
[  328.381291] NVRM: Try unloading the conflicting kernel module (and/or
               NVRM: reconfigure your kernel without the conflicting
               NVRM: driver(s)), then try loading the NVIDIA kernel module
               NVRM: again.
[  328.381291] NVRM: No NVIDIA devices probed.
[  328.381908] nvidia-nvlink: Unregistered Nvlink Core, major device number 506
[  328.631149] nvidia-nvlink: Nvlink Core is being initialized, major device number 506
[  328.631153] NVRM: The NVIDIA probe routine was not called for 1 device(s).
[  328.632004] NVRM: This can occur when a driver such as:
               NVRM: nouveau, rivafb, nvidiafb or rivatv
               NVRM: was loaded and obtained ownership of the NVIDIA device(s).
[  328.632005] NVRM: Try unloading the conflicting kernel module (and/or
               NVRM: reconfigure your kernel without the conflicting
               NVRM: driver(s)), then try loading the NVIDIA kernel module
               NVRM: again.
[  328.632005] NVRM: No NVIDIA devices probed.
[  328.632594] nvidia-nvlink: Unregistered Nvlink Core, major device number 506
[  328.879127] nvidia-nvlink: Nvlink Core is being initialized, major device number 506
[  328.879130] NVRM: The NVIDIA probe routine was not called for 1 device(s).
[  328.879999] NVRM: This can occur when a driver such as:
               NVRM: nouveau, rivafb, nvidiafb or rivatv
               NVRM: was loaded and obtained ownership of the NVIDIA device(s).
[  328.880000] NVRM: Try unloading the conflicting kernel module (and/or
               NVRM: reconfigure your kernel without the conflicting
               NVRM: driver(s)), then try loading the NVIDIA kernel module
               NVRM: again.
[  328.880000] NVRM: No NVIDIA devices probed.

from what i read so far acpi is usually hardware related ? Also my keyboard input layout changed…

Any further ideas?
blacklisting nvidiafb and nouveau does not yield anything fruitfull.
ALso the Device cant be shut down anymore by e.g “shutdown now” but hangs on a balck screen.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Processing: nvidia-bug-report.log.gz…

how long is the upload supposed to take… ?

When that appears, forever. The virus scanner is stuck again.
Please try unzipping and attaching it as text.

nvidia-bug-report.log (12.8 MB)

Unfortunately, early boot messages were pushed out by the error message flood. Please create a dmesg output immediately after reboot and attach that.

dmseg.out (277.2 KB)

UPDATE:
Disabling FastBoot made the Driver loadable again. dmseg still lists the ACPI error. The keyboard is back to its set layout.
I will check weather the black screen issue is resolved as well. I do not think so, as dmseg still says:
[ 24.132271] [drm:nv_drm_master_set [nvidia_drm]] ERROR [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership

dmsegNoFastBoot.out (104.3 KB)

nvidia-bug-report-NoFastBoot.log (17.4 MB)

also i just realized the ouput device changed from eDP to DP-4

and i forgot to mention: I also disabled dual gpu in the BIOS

dmsegNoFastBootDualGPU.out (150.8 KB)

The kernel has issues properly adding the nvidia gpu so the driver can’t load:

[    0.966291] sysfs: cannot create duplicate filename '/devices/pci0000:00/0000:00:01.0/0000:01:00.0/resource0'
[    0.966293] CPU: 2 PID: 208 Comm: irq/122-pciehp Not tainted 5.15.0-41-generic #44-Ubuntu
[    0.966294] Hardware name: LENOVO 82RF/LNVNB161216, BIOS J2CN40WW 04/15/2022
[    0.966295] Call Trace:
[    0.966296]  <TASK>
[    0.966297]  show_stack+0x52/0x58
[    0.966300]  dump_stack_lvl+0x4a/0x5f
[    0.966303]  dump_stack+0x10/0x12
[    0.966304]  sysfs_warn_dup.cold+0x17/0x27
[    0.966306]  sysfs_add_file_mode_ns+0x166/0x170
[    0.966309]  sysfs_create_bin_file+0x64/0x90
[    0.966311]  pci_create_attr+0x147/0x220
[    0.966313]  pci_create_resource_files+0x6f/0x150
[...]
[    1.047463] Fixing recursive fault but reboot is needed!

Please check if upgrading the kernel using the liquorix ppa fixes this.