Intent Slot Classification missing default model

@SunilJB
I ran into another issue where the preset notebook content does not work.

This cell does not work due to the default model not being created. Is this intentional?

These are the jmir models created from the jarvis-deploy command
image
To fix this how am I supposed to create the intent_slot_default so that I can apply this model on different domains and not just the weather domain? Does the default domain model not get created?

Let me know if you need any logs. Your help and insight is really appreciated.
Thanks

Hi @sek2
The <domain_name> is appended to “jarvis_intent_” to look for a model “jarvis_intent_<domain_name>”. So the model “jarvis_intent_default” needs to be preloaded in jarvis server.
You can specify the domain name of the model using --domain_name arg during build process. Please refer below link:
https://docs.nvidia.com/deeplearning/jarvis/user-guide/docs/service-nlp.html#token-classification-named-entity-recognition

In notebook, below section needs to be updated to specify the custom domain name

Thanks

I am having the same issue. Is this resolved by using --domain_name during build process in notebook?

@sek2 @SunilJB Kindly respond.

Hi @meravleen,
Did you tried specifying the custom domain name as suggested above?
Could you please share the error log so we can help better in this case?

Thanks

!docker run --rm --gpus 1 -v $MODEL_LOC:/data $RIVA_SM_CONTAINER –
riva-build intent_slot -f --domain_name=‘default’ /data/intent-slot.rmir:$KEY /data/$MODEL_NAME:$KEY

the folder has the model
/home/ubuntu/tao/results/intent_slot_classification/export_riva/models
ubuntu@ip-172-31-14-240:~/tao/results/intent_slot_classification/export_riva/models$ ls
riva-trt-riva_intent_default-nn-bert-base-uncased
riva-trt-riva_intent_”default”-nn-bert-base-uncased
riva_detokenize
riva_intent_default
riva_intent_”default”
riva_label_tokens
riva_label_tokens_default
riva_label_tokens_”default”
riva_tokenizer

Here are the failure logs

_InactiveRpcError Traceback (most recent call last)
in ()
1 run_intent_slot(grpc_server=“localhost:50051”,
----> 2 query=[“Please set an alarm for 6 am”, “Play some pop music”])

in run_intent_slot(grpc_server, query)
15 # custom Joint Intent and Slot model use the --domain_name parameter in
16 # ServiceMaker’s riva-build intent_slot command.
—> 17 resp = riva_nlp.AnalyzeIntent(req)
18
19 print(“Query:”, q)

/home/ubuntu/.local/lib/python3.6/site-packages/grpc/_channel.py in call(self, request, timeout, metadata, credentials, wait_for_ready, compression)
944 state, call, = self._blocking(request, timeout, metadata, credentials,
945 wait_for_ready, compression)
→ 946 return _end_unary_response_blocking(state, call, False, None)
947
948 def with_call(self,

/home/ubuntu/.local/lib/python3.6/site-packages/grpc/_channel.py in _end_unary_response_blocking(state, call, with_call, deadline)
847 return state.response
848 else:
→ 849 raise _InactiveRpcError(state)
850
851

_InactiveRpcError: <_InactiveRpcError of RPC that terminated with:
status = StatusCode.UNAVAILABLE
details = “Error: Model riva_intent_default is not a Riva API model, execution cannot be done”
debug_error_string = “{“created”:”@1630573683.812723422",“description”:“Error received from peer ipv6:[::1]:50051”,“file”:“src/core/lib/surface/call.cc”,“file_line”:1066,“grpc_message”:“Error: Model riva_intent_default is not a Riva API model, execution cannot be done”,“grpc_status”:14}"

The model created by the training notebook exists in export_riva folder.
ubuntu@ip-172-31-14-240:~/tao/results/intent_slot_classification/export_riva$ ls
export.log intent-slot-model.riva intent-slot.rmir models

also tried with a different domain name… Same error is shown.