Is this expected behavior? Tesla M60

I am having issues with vGPU implementation under vsphere 6. I can get a vm to run (Windows 10) with 3D graphics acceleration. (3D works and I can hear the M60 Tesla fans kick in when benchmarking).

However if I try to bring up a second vm using vGPU vsphere tells me there are insufficient resources.

If I do a query such as:
[root@mm00917:~] lspci -n | grep 10de
0000:03:00.0 Class 0300: 10de:13f2 [vmgfx1]
0000:04:00.0 Class 0300: 10de:13f2 [vmgfx0]
0000:05:00.0 Class 0300: 10de:1c03
0000:05:00.1 Class 0403: 10de:10f1

The above seems rather short? Also, if I query nvidia-smi the below is returned, the master VM seems to have chewed up a lot of the cards memory:

Every 1s: nvidia-smi 2016-09-15 01:12:03

Thu Sep 15 01:12:03 2016
| NVIDIA-SMI 367.43 Driver Version: 367.43 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 Tesla M60 On | 0000:03:00.0 Off | Off |
| 32% 41C P8 26W / 120W | 7636MiB / 8191MiB | 0% Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
| 0 51148 C+G vGPU-Master 7616MiB |

Does this all look nominal? Unsure what I am doing incorrectly?

If you search for insufficient in the release notes there is some advice on this: Known Issues and Resolved issues: Release Notes GRID VGPU FOR VMWARE VSPHERE - Version 361.40 / 362.13 - April 4th, 2016 | NVIDIA

You need to make sure the memory was statically allocated to the VM

Also check your licensing View 6.1 w/ Nvidia K1 Error booting up machine aft... - VMware Technology Network VMTN

Can you also check: Having problems with new M6/M60 like VMs fail to power on, NVRM BAR1 error, ECC is enabled, or nvidia-smi fails | NVIDIA and follow the instructions on using # esxcfg-info -a | less

And scroll or search down to Tesla M60 label.

Further research got me to the bottom of the issue, I had not allocated the correct GRID profile per memory allocation for the machines.

The system is now running normally.


Thanks for letting us know Simon - glad you got it sorted!