Issue accessing public rtsp stream?

Hardware: dgpu rtx 2070
Deepstream: 5.1
Cuda: 11.2

gst-launch-1.0 rtspsrc location=rtsp://user:delhivery%40456@125.18.57.250:2554/Streaming/channels/1801 latency=0 drop-on-latency=true rtsp-keep-alive=true protocols=tcp ! rtph264depay ! nvv4l2decoder ! nvvideoconvert ! videorate ! video/x-raw, width=640, height=360, framerate=2/1 ! videoconvert ! autovideosink sync=false

The above shared pipeline with v4l2decoder causes issue but the avdec_h264 isn’t an issue. Any idea how to fix it?

The following is a pipeline which works,

gst-launch-1.0 rtspsrc location=rtsp://user:delhivery%40456@125.18.57.250:2554/Streaming/channels/1801 latency=0 drop-on-latency=true rtsp-keep-alive=true protocols=tcp ! rtph264depay ! avdec_h264 ! nvvideoconvert ! videorate ! video/x-raw, width=640, height=360, framerate=2/1 ! videoconvert ! autovideosink sync=false

I’ve tried the following pipeline in my device, it can work:

gst-launch-1.0 rtspsrc location=rtsp://xxxxxx ! rtph264depay ! nvv4l2decoder ! nvvideoconvert ! videorate ! 'video/x-raw, framerate=2/1' ! videoconvert ! autovideosink

I just tested with the pipeline you had shared above and it doesn’t seem to play anything, the above shared rtsp url is a public one. This is the log I get,

Setting pipeline to PAUSED …
Pipeline is live and does not need PREROLL …
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://user:delhivery%40456@125.18.57.250:2554/Streaming/channels/1801
Progress: (open) Retrieving server options
Progress: (open) Retrieving media info
Progress: (request) SETUP stream 0
Progress: (open) Opened Stream
Setting pipeline to PLAYING …
New clock: GstSystemClock
Progress: (request) Sending PLAY request
Progress: (request) Sending PLAY request
Progress: (request) Sent PLAY request
WARNING: from element /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0: Could not read from resource.
Additional debug info:
gstrtspsrc.c(5768): gst_rtspsrc_reconnect (): /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0:
Could not receive any UDP packets for 5.0000 seconds, maybe your firewall is blocking it. Retrying using a tcp connection.

I’ve changed the protocol to tcp in deepstream too yet it doesn’t work. Any suggestions. The above shared public rtsp endpoint is working in vlc