Issue: nvdecompress fails to decompress DDS with BC1_SRGB format

Hi,

I’ve tried to decompress a dds file that has BC1_SRGB format with nvdecompress.exe, but it fails with the following message: “Error opening input file ‘E:\a.DDS’.”.

I’ve attempted the decompression with the executable that came alongside the NVIDIA Texture Tools 3 Version 3.1.6 stand alone application.

The same error occured with nvtt_decompress, from https://github.com/nvpro-samples/nvtt_samples. Commit hash: 95ab67812b237f7f798b5b1cf0a6f2129bc910ef.

I’ve attached the file which I tried to decompress.

Could you help me solve this issue?

Thanks for the help!
example_bc1_srgb.dds (2.8 KB)

Hi user54329!

Try changing the DX10 format to DXGI_FORMAT_BC1_UNORM by changing byte 0x80 of the DDS file from 0x48 to 0x47. (I’ve attached a modified version of the file so you can see what changed).

Looks like the DDS reader in NVTT was returning “unsupported” for these sRGB formats; nvtt_export.exe uses a different DDS reader, so that’s likely why you might have noticed it’s readable in nvtt_export but not NVTT.

Thanks!

example_bc1_srgb_modified.dds (2.8 KB)