Issue with Checkpoint functionality (CRIU) in Jetson Xavier AGX

I use Jetson Xavier AGX. with 4.9.201 tegra kernel on ubuntu 18.04

Inorder to checkpoint the running nvidia docker containers, I use checkpoint restore functionality provided by CRIU tool.
I have installed CRIU version3.11 . so In order to use the checkpoint functionality, certain features has to be enabled in the linux kernel .config file (Linux kernel - CRIU). So i have modified the .config file accordingly in the location

/usr/src/linux-headers-4.9.201-tegra-ubuntu18.04_aarch64/kernel-4.9/

followed by $ sudo make.
I get the following error message.

scripts/kconfig/conf --silentoldconfig Kconfig
drivers/net/ethernet/nvidia/Kconfig:30: can’t open file “drivers/net/ethernet/nvidia/eqos/Kconfig”
scripts/kconfig/Makefile:37: recipe for target ‘silentoldconfig’ failed
make[2]: *** [silentoldconfig] Error 1
Makefile:565: recipe for target ‘silentoldconfig’ failed
make[1]: *** [silentoldconfig] Error 2
make: *** No rule to make target ‘include/config/auto.conf’, needed by ‘include/config/kernel.release’. Stop.

Please help!

hello ksrinidhi23,

had you refer to Kernel Customization for setting up development environment to build nvidia kernel?

Hello JerryChang,
I have refered to the documentation. But even after that i got the same error.

So, By taking a new xavier board , in the directory
“/usr/src/linux-headers-4.9.201-tegra-ubuntu18.04_aarch64/kernel-4.9/”
I tried to just run $sudo make without making any modifications.
The same error comes up.

abc@xyz:/usr/src/linux-headers-4.9.201-tegra-ubuntu18.04_aarch64/kernel-4.9$ sudo make
HOSTCC scripts/kconfig/conf.o
HOSTCC scripts/kconfig/zconf.tab.o
HOSTLD scripts/kconfig/conf
scripts/kconfig/conf --silentoldconfig Kconfig
drivers/net/ethernet/nvidia/Kconfig:30: can’t open file “drivers/net/ethernet/nvidia/eqos/Kconfig”
scripts/kconfig/Makefile:37: recipe for target ‘silentoldconfig’ failed
make[2]: *** [silentoldconfig] Error 1
Makefile:579: recipe for target ‘silentoldconfig’ failed
make[1]: *** [silentoldconfig] Error 2
make: *** No rule to make target ‘include/config/auto.conf’, needed by ‘include/config/kernel.release’. Stop.

I couldnot identify the problems… Please do help.

hello ksrinidhi23,

where did you build the sources, on the x86 host machine?
please check you’re using correct toolchain also, Jetson Linux Toolchain.
thanks

Hello thank you so much. Your guidance was useful.