Issue with downloading Pre-trained TLT models

Hi,

I have been trying out the Nvidia TLT but I am having issues downloading the pre trained models. I understand that we have to use the following command with our API key to download the models

tlt-pull --list_models -k $API_KEY -o $ORG -t $TEAM

and use nvtltea/iva for the -o and -t argument. However, I am still unable to get access to the list of models available.

I understand from other forum posts here that users have to choose nvtltea/iva while logging-in but I do not get the option to do that. Is there any why I can sign-up/apply to get access to nvtltea/iva on my account?

Some guidance in this regard would be highly appreciated.

Thank-you!

Hi daanyal,
Your attached command is a command to get a list of pre-trained models. Could you try again if you can get any output?
$ tlt-pull -k $API_KEY -lm -o nvtltea -t iva

For $API_KEY, please check the page 3~4 in https://devtalk.nvidia.com/default/topic/1050234/transfer-learning-toolkit/announcements/

I ran the command you mentioned above but it still would not run. This was the response I got after running the command:

Invalid org. Choose from ['dqxg9akguuul']

As for the $API_KEY, I have already generated it as per the instructions given. Also, while initially creating the account, it did not prompt me to choose the Organization/Team as mentioned in the getting started guide.

Hi daanyal,
Seems that you have not a valid account. Could you follow the 3rd page of the pdf document to create an account.
[i]
Get an NGC API Key
‣ NVIDIA GPU Cloud account and API key - https://ngc.nvidia.com/

  1. Go to NGC and click the Transfer Learning Toolkit container in the Catalog
    tab. This message is displayed, Sign in to access the PULL feature of this
    repository.
  2. Enter your email address and click Next or click Create an Account.
  3. Choose your organization when prompted for Organization/Team.
    Your organization should be the first choice listed in the Set Your Organization
    dialog.
  4. Click Sign In.
  5. Select the Containers tab on the left navigation pane and click the Transfer
    Learning Toolkit tile.
    [/i]

Hi Morgan,

I tried making a new account using a different email but it still does not prompt me for Organization/Team selection.

When you open ngc.nvidia.com with browser, are you able to see any Organization/Team selection for you to sign in?

No I do not see it.

I will ask internal team to check your account.

Yes kindly please do.

And thank you very much for the help!

Hi Daanyal,
The nvtltea/iva is only for EA of TLT. We have closed EA program and we will have GA soon.
So, please wait for the GA version of TLT. Thanks.

Thank you very much for letting me know.