Issues while installing CUDA 8.0 on CENTOS 7

I am running into problems trying to install CUDA 8.0 om my machine.
I’ll appreciate any response.

I have CUDA 7.5 installed.

1.) I remove the previous version
$ sudo yum remove cuda

2.) Download RPM (Local)
3.) Install the RPM
sudo rpm -i cuda-repo-rhel7-8-0-local-8.0.44-1.x86_64.rpm sudo yum clean expire-cache
$ sudo yum install cuda

I am getting the following error message:
Retrieving key from http://developer.download.nvidia.com/compute/cuda/repos/GPGKEY

The GPG keys listed for the “cuda” repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.

Failing package is: cuda-cusparse-8-0-8.0.44-1.x86_64
GPG Keys are configured as: http://developer.download.nvidia.com/compute/cuda/repos/GPGKEY

HERE IS THE COMPLETE OUTPUT

$ sudo yum install cuda
Loaded plugins: fastestmirror, langpacks
base | 3.6 kB 00:00:00
cuda | 2.5 kB 00:00:00
cuda-8-0-local | 2.5 kB 00:00:00
elrepo | 2.9 kB 00:00:00
epel/x86_64/metalink | 13 kB 00:00:00
epel | 4.3 kB 00:00:00
extras | 3.4 kB 00:00:00
google-chrome | 951 B 00:00:00
updates | 3.4 kB 00:00:00
(1/10): cuda-8-0-local/primary_db | 15 kB 00:00:00
(2/10): base/7/x86_64/group_gz | 155 kB 00:00:00
(3/10): epel/x86_64/group_gz | 170 kB 00:00:00
(4/10): epel/x86_64/updateinfo | 669 kB 00:00:00
(5/10): base/7/x86_64/primary_db | 5.3 MB 00:00:00
(6/10): cuda/primary_db | 71 kB 00:00:00
(7/10): extras/7/x86_64/primary_db | 166 kB 00:00:00
(8/10): epel/x86_64/primary_db | 4.3 MB 00:00:00
(9/10): updates/7/x86_64/primary_db | 9.1 MB 00:00:00
(10/10): elrepo/primary_db | 411 kB 00:00:00
google-chrome/primary | 2.0 kB 00:00:00
Determining fastest mirrors

  • base: mirror.jaleco.com
  • elrepo: iad.mirror.rackspace.com
  • epel: mirror.us.leaseweb.net
  • extras: mirror.jaleco.com
  • updates: mirror.jaleco.com
    google-chrome 3/3
    Resolving Dependencies
    –> Running transaction check
    —> Package cuda.x86_64 0:8.0.44-1 will be installed
    –> Processing Dependency: cuda-8-0 >= 8.0.44 for package: cuda-8.0.44-1.x86_64
    –> Running transaction check
    —> Package cuda-8-0.x86_64 0:8.0.44-1 will be installed
    –> Processing Dependency: cuda-toolkit-8-0 >= 8.0.44 for package: cuda-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-runtime-8-0 >= 8.0.44 for package: cuda-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-demo-suite-8-0 >= 8.0.44 for package: cuda-8-0-8.0.44-1.x86_64
    –> Running transaction check
    —> Package cuda-demo-suite-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-runtime-8-0.x86_64 0:8.0.44-1 will be installed
    –> Processing Dependency: cuda-nvrtc-8-0 >= 8.0.44 for package: cuda-runtime-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-nvgraph-8-0 >= 8.0.44 for package: cuda-runtime-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-npp-8-0 >= 8.0.44 for package: cuda-runtime-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-license-8-0 >= 8.0.44 for package: cuda-runtime-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-drivers >= 361.93 for package: cuda-runtime-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-cusparse-8-0 >= 8.0.44 for package: cuda-runtime-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-cusolver-8-0 >= 8.0.44 for package: cuda-runtime-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-curand-8-0 >= 8.0.44 for package: cuda-runtime-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-cufft-8-0 >= 8.0.44 for package: cuda-runtime-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-cudart-8-0 >= 8.0.44 for package: cuda-runtime-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-cublas-8-0 >= 8.0.44 for package: cuda-runtime-8-0-8.0.44-1.x86_64
    —> Package cuda-toolkit-8-0.x86_64 0:8.0.44-1 will be installed
    –> Processing Dependency: cuda-visual-tools-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-samples-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-nvrtc-dev-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-nvml-dev-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-nvgraph-dev-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-npp-dev-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-misc-headers-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-driver-dev-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-documentation-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-cusparse-dev-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-cusolver-dev-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-curand-dev-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-cufft-dev-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-cudart-dev-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-cublas-dev-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-core-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Processing Dependency: cuda-command-line-tools-8-0 >= 8.0.44 for package: cuda-toolkit-8-0-8.0.44-1.x86_64
    –> Running transaction check
    —> Package cuda-command-line-tools-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-core-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-cublas-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-cublas-dev-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-cudart-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-cudart-dev-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-cufft-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-cufft-dev-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-curand-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-curand-dev-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-cusolver-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-cusolver-dev-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-cusparse-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-cusparse-dev-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-documentation-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-driver-dev-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-drivers.x86_64 0:352.99-0 will be updated
    —> Package cuda-drivers.x86_64 0:367.48-1 will be an update
    –> Processing Dependency: xorg-x11-drv-nvidia-libs(x86-64) >= 1:367.48 for package: cuda-drivers-367.48-1.x86_64
    –> Processing Dependency: xorg-x11-drv-nvidia-gl(x86-64) >= 1:367.48 for package: cuda-drivers-367.48-1.x86_64
    –> Processing Dependency: xorg-x11-drv-nvidia-devel(x86-64) >= 1:367.48 for package: cuda-drivers-367.48-1.x86_64
    –> Processing Dependency: xorg-x11-drv-nvidia >= 1:367.48 for package: cuda-drivers-367.48-1.x86_64
    –> Processing Dependency: nvidia-kmod >= 1:367.48 for package: cuda-drivers-367.48-1.x86_64
    —> Package cuda-license-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-misc-headers-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-npp-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-npp-dev-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-nvgraph-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-nvgraph-dev-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-nvml-dev-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-nvrtc-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-nvrtc-dev-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-samples-8-0.x86_64 0:8.0.44-1 will be installed
    —> Package cuda-visual-tools-8-0.x86_64 0:8.0.44-1 will be installed
    –> Running transaction check
    —> Package nvidia-kmod.x86_64 1:352.99-2.el7 will be updated
    —> Package nvidia-kmod.x86_64 1:352.99-2.el7 will be obsoleted
    —> Package nvidia-kmod.x86_64 1:367.48-2.el7 will be obsoleting
    —> Package nvidia-uvm-kmod.x86_64 1:352.99-3.el7 will be obsoleted
    —> Package xorg-x11-drv-nvidia.x86_64 1:352.99-1.el7 will be updated
    —> Package xorg-x11-drv-nvidia.x86_64 1:367.48-1.el7 will be obsoleting
    —> Package xorg-x11-drv-nvidia-devel.x86_64 1:352.99-1.el7 will be updated
    —> Package xorg-x11-drv-nvidia-devel.x86_64 1:367.48-1.el7 will be an update
    —> Package xorg-x11-drv-nvidia-gl.x86_64 1:352.99-1.el7 will be updated
    —> Package xorg-x11-drv-nvidia-gl.x86_64 1:367.48-1.el7 will be an update
    —> Package xorg-x11-drv-nvidia-libs.x86_64 1:352.99-1.el7 will be updated
    —> Package xorg-x11-drv-nvidia-libs.x86_64 1:367.48-1.el7 will be an update
    –> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================
Package Arch Version Repository Size

Installing:
cuda x86_64 8.0.44-1 cuda 5.7 k
nvidia-kmod x86_64 1:367.48-2.el7 cuda 7.1 M
replacing nvidia-uvm-kmod.x86_64 1:352.99-3.el7
xorg-x11-drv-nvidia x86_64 1:367.48-1.el7 cuda 5.1 M
replacing nvidia-kmod.x86_64 1:352.99-2.el7
Installing for dependencies:
cuda-8-0 x86_64 8.0.44-1 cuda 5.8 k
cuda-command-line-tools-8-0 x86_64 8.0.44-1 cuda 25 M
cuda-core-8-0 x86_64 8.0.44-1 cuda 19 M
cuda-cublas-8-0 x86_64 8.0.44-1 cuda 25 M
cuda-cublas-dev-8-0 x86_64 8.0.44-1 cuda 54 M
cuda-cudart-8-0 x86_64 8.0.44-1 cuda 136 k
cuda-cudart-dev-8-0 x86_64 8.0.44-1 cuda 1.0 M
cuda-cufft-8-0 x86_64 8.0.44-1 cuda 112 M
cuda-cufft-dev-8-0 x86_64 8.0.44-1 cuda 90 M
cuda-curand-8-0 x86_64 8.0.44-1 cuda 42 M
cuda-curand-dev-8-0 x86_64 8.0.44-1 cuda 65 M
cuda-cusolver-8-0 x86_64 8.0.44-1 cuda 28 M
cuda-cusolver-dev-8-0 x86_64 8.0.44-1 cuda 6.5 M
cuda-cusparse-8-0 x86_64 8.0.44-1 cuda 27 M
cuda-cusparse-dev-8-0 x86_64 8.0.44-1 cuda 28 M
cuda-demo-suite-8-0 x86_64 8.0.44-1 cuda 4.8 M
cuda-documentation-8-0 x86_64 8.0.44-1 cuda 103 M
cuda-driver-dev-8-0 x86_64 8.0.44-1 cuda 18 k
cuda-license-8-0 x86_64 8.0.44-1 cuda 31 k
cuda-misc-headers-8-0 x86_64 8.0.44-1 cuda 1.1 M
cuda-npp-8-0 x86_64 8.0.44-1 cuda 150 M
cuda-npp-dev-8-0 x86_64 8.0.44-1 cuda 79 M
cuda-nvgraph-8-0 x86_64 8.0.44-1 cuda 2.8 M
cuda-nvgraph-dev-8-0 x86_64 8.0.44-1 cuda 2.9 M
cuda-nvml-dev-8-0 x86_64 8.0.44-1 cuda 50 k
cuda-nvrtc-8-0 x86_64 8.0.44-1 cuda 9.1 M
cuda-nvrtc-dev-8-0 x86_64 8.0.44-1 cuda 15 k
cuda-runtime-8-0 x86_64 8.0.44-1 cuda 6.0 k
cuda-samples-8-0 x86_64 8.0.44-1 cuda 96 M
cuda-toolkit-8-0 x86_64 8.0.44-1 cuda 6.7 k
cuda-visual-tools-8-0 x86_64 8.0.44-1 cuda 271 M
Updating for dependencies:
cuda-drivers x86_64 367.48-1 cuda 2.8 k
xorg-x11-drv-nvidia-devel x86_64 1:367.48-1.el7 cuda 3.9 M
xorg-x11-drv-nvidia-gl x86_64 1:367.48-1.el7 cuda 19 M
xorg-x11-drv-nvidia-libs x86_64 1:367.48-1.el7 cuda 31 M

Transaction Summary

Install 3 Packages (+31 Dependent packages)
Upgrade ( 4 Dependent packages)

Total download size: 1.3 G
Is this ok [y/d/N]: y
Downloading packages:
No Presto metadata available for cuda
warning: /var/cache/yum/x86_64/7/cuda/packages/cuda-8.0.44-1.x86_64.rpm: Header V3 RSA/SHA512 Signature, key ID 7fa2af80: NOKEY
Public key for cuda-8.0.44-1.x86_64.rpm is not installed
(1/38): cuda-8.0.44-1.x86_64.rpm | 5.7 kB 00:00:00
(2/38): cuda-8-0-8.0.44-1.x86_64.rpm | 5.8 kB 00:00:00
(3/38): cuda-core-8-0-8.0.44-1.x86_64.rpm | 19 MB 00:00:02
(4/38): cuda-command-line-tools-8-0-8.0.44-1.x86_64.rpm | 25 MB 00:00:02
(5/38): cuda-cublas-8-0-8.0.44-1.x86_64.rpm | 25 MB 00:00:03
(6/38): cuda-cudart-8-0-8.0.44-1.x86_64.rpm | 136 kB 00:00:00
(7/38): cuda-cudart-dev-8-0-8.0.44-1.x86_64.rpm | 1.0 MB 00:00:00
(8/38): cuda-cublas-dev-8-0-8.0.44-1.x86_64.rpm | 54 MB 00:00:05
(9/38): cuda-cufft-dev-8-0-8.0.44-1.x86_64.rpm | 90 MB 00:00:08
(10/38): cuda-cufft-8-0-8.0.44-1.x86_64.rpm | 112 MB 00:00:14
(11/38): cuda-curand-8-0-8.0.44-1.x86_64.rpm | 42 MB 00:00:05
(12/38): cuda-cusolver-8-0-8.0.44-1.x86_64.rpm | 28 MB 00:00:03
(13/38): cuda-cusolver-dev-8-0-8.0.44-1.x86_64.rpm | 6.5 MB 00:00:01
(14/38): cuda-cusparse-8-0-8.0.44-1.x86_64.rpm | 27 MB 00:00:04
(15/38): cuda-curand-dev-8-0-8.0.44-1.x86_64.rpm | 65 MB 00:00:10
(16/38): cuda-demo-suite-8-0-8.0.44-1.x86_64.rpm | 4.8 MB 00:00:00
(17/38): cuda-cusparse-dev-8-0-8.0.44-1.x86_64.rpm | 28 MB 00:00:04
(18/38): cuda-driver-dev-8-0-8.0.44-1.x86_64.rpm | 18 kB 00:00:00
(19/38): cuda-drivers-367.48-1.x86_64.rpm | 2.8 kB 00:00:00
(20/38): cuda-license-8-0-8.0.44-1.x86_64.rpm | 31 kB 00:00:00
(21/38): cuda-misc-headers-8-0-8.0.44-1.x86_64.rpm | 1.1 MB 00:00:00
(22/38): cuda-documentation-8-0-8.0.44-1.x86_64.rpm | 103 MB 00:00:16
(23/38): cuda-npp-8-0-8.0.44-1.x86_64.rpm | 150 MB 00:00:18
(24/38): cuda-nvgraph-8-0-8.0.44-1.x86_64.rpm | 2.8 MB 00:00:00
(25/38): cuda-nvgraph-dev-8-0-8.0.44-1.x86_64.rpm | 2.9 MB 00:00:00
(26/38): cuda-nvml-dev-8-0-8.0.44-1.x86_64.rpm | 50 kB 00:00:00
(27/38): cuda-nvrtc-8-0-8.0.44-1.x86_64.rpm | 9.1 MB 00:00:01
(28/38): cuda-nvrtc-dev-8-0-8.0.44-1.x86_64.rpm | 15 kB 00:00:00
(29/38): cuda-runtime-8-0-8.0.44-1.x86_64.rpm | 6.0 kB 00:00:00
(30/38): cuda-npp-dev-8-0-8.0.44-1.x86_64.rpm | 79 MB 00:00:10
(31/38): cuda-toolkit-8-0-8.0.44-1.x86_64.rpm | 6.7 kB 00:00:00
(32/38): cuda-samples-8-0-8.0.44-1.x86_64.rpm | 96 MB 00:00:13
(33/38): nvidia-kmod-367.48-2.el7.x86_64.rpm | 7.1 MB 00:00:01
(34/38): xorg-x11-drv-nvidia-367.48-1.el7.x86_64.rpm | 5.1 MB 00:00:01
(35/38): xorg-x11-drv-nvidia-devel-367.48-1.el7.x86_64.rpm | 3.9 MB 00:00:00
(36/38): xorg-x11-drv-nvidia-gl-367.48-1.el7.x86_64.rpm | 19 MB 00:00:03
(37/38): xorg-x11-drv-nvidia-libs-367.48-1.el7.x86_64.rpm | 31 MB 00:00:03
(38/38): cuda-visual-tools-8-0-8.0.44-1.x86_64.rpm | 271 MB 00:00:41

Total 13 MB/s | 1.3 GB 00:01:41
Retrieving key from http://developer.download.nvidia.com/compute/cuda/repos/GPGKEY

The GPG keys listed for the “cuda” repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.

Failing package is: cuda-cusparse-8-0-8.0.44-1.x86_64
GPG Keys are configured as: http://developer.download.nvidia.com/compute/cuda/repos/GPGKEY

============================================================

I don’t know what the source of the error is.

As possible suggestions, you could try using a clean install of the OS.

Alternatively, you could follow the instructions in the linux install guide to remove old installs, then try again using the runfile installer method instead of the package manager method.

Thank you for your response.
The runfile installer did fix the problem.

I had the same issue. Note that the GPG keys were replaced for RSA/SHA512 new ones.

You also have to update for example to this GPG key.
http://developer.download.nvidia.com/compute/cuda/repos/rhel7/x86_64/7fa2af80.pub

Dear mjtrangoni,

I have similar problem on CentOS 7, would you please point to me what should I do to fix it ? I am beginner in this field… thanks.

https://devtalk.nvidia.com/default/topic/1009727/linux/error-nvidia-settings-could-not-find-the-registry-key-file/