Issues with Jupyter Notebook installation

Hi everyone,
We are using Jetson Nano Dev board for recognizing some particular objects and we have a code that dose that developed for us by using Google Collaboratory.
Now I need to get it working on the Jetson Nano board. To do that I need to have TensorFlow 2 and Jupiter Notebook installed on the board.
I did TF installation by using Jetson Official TensorFlow guide from here: Official TensorFlow for Jetson Nano!.
Than I did installation of Jupyter Notebook by using pip3.
I was working ok, but than I needed to install matplotlib, so I did it, and it gave me error: “ERROR: Failed building wheel for pyzmq”
I tried to install pyzmq manually, and it gave same error.
And now it is giving me same errors for pyzmq, argon2_cffi and some other packages that intalls by pip.
Can anyone give me an advise how to fix it.

Short answer:

Accoriding to the “” found in the nvidia DLI: Getting Started with AI on the Jetson Nano, you’ll see the following list:

If you install these in order, then Jupyter Lab will work. Note, I changed the link to Node.js to link a link that was a response to another post. Following those instructions caused no grief (some other ways don’t produce the same results).

If you need a more detailed, and step by step instructions on how to get your Nano set up, I wrote on Medium article called: The Newbie Guite to Setting Up a Jetson Nano on JP4.4 Part 1: Running Jupyter Lab Headless Using SSH. That will step you through the process of getting Jupyter Lab set up and running corectly.


1 Like

Have a reference to below to check.

Sorry, forgot to mention. It sounds like your errors are because you’re missing libffi-dev.

If you do this:

$ sudo apt install libffi-dev

Then run your Jupyter install again, it should clear up the errors in your case.

I ran into similar issues when installing Jupyter Lab, aded that package and everything worked. I was also having troubles installing scipy and other packages (cython) as well. Until I installed that package.

Thanks guys for answering me.
I did try all of your recommendations; unfortunately, nothing work.
I did reinstall pyzmq version 17.0.0: same issue.
I did install all of the packages from “” list.
By the way I had “libffi-dev” already installed.
And this did not help me either.
Now when I do “pip3 install jupyterlab” it giving me “Failed to build argon2-cffi pyzmq” error.
But when I try to run jupyter notebook; it is giving me this:

Traceback (most recent call last):
File “/home/licap/.local/bin/jupyter”, line 5, in
from jupyter_core.command import main
ModuleNotFoundError: No module named ‘jupyter_core’

Thanks for advise

  • Are you installing inside a virtual environment?

  • What version of node.js do you have installed? Can you check by running :

$  node -v

You need to have version: v12.13.0

as well as npm

$ npm -v

npm needs to be: 6.12.0

Some of the erros you bring up sound familiar, I’ve seen them in my own experience trying to install, that’s why I ask.

Also, how did you install node.js? It sounds strange, but any other way than following the directions on that link I sent don’t seem to work (they say node.js is up to date when I do an apt install, or pip3 install, but these versions are < v12.13.0 when I check, so make sure these are up to date. Jupyter relies allot on node.js.

Thanks for the answer.
No I am not using virtual environment. For some reason venv stopped working as well.
node -v gives me v12.13.0
npm -v - 6.12.0
for Node.js I did followed link that you gave me here * Node.js

It look what it need to look for me.

Thanks, my last questions would be this:

  1. Did you get any warnings when installing? (Some warinings saying you should install using “sudo -H”)?
  2. How did you install Jupyter? What was the exact command?

Did you do the following prior to installing jupyter:

$ export PATH="$HOME/.local/bin:$PATH"

and did you install it this way:

$ pip3 install --user jupyterlab

(You need to type that all in, including --user jupyterlab)

It’s a little different method than what is usually described, but doing it that way gave me no warnings or issues. If you’ve tried that and still can’t get things working, then I’m out of ideas. Sorry.

Thanks for replying.
Yes I did get such warnings on some of installs.
And I did not do export PATH command before jupyterlab install.
I did

$ pip3 install jupyterlab

However it was working okey giving me access to home folder.
And than it stopped after install of matplotlib.
Now, I just did those two commands that you suggested.
Unfortunately, I got exactly same result.
Probably, I will do fresh reinstall aging.
The only think that I do like to know, is there any special order of installing such products as:

tensorflow 2
jupyter notebook


As much as I hate saying this, I agree with you on re-installing. I hate saying it because of the amount of times I’ve done it myself! I guess on the bright side, at least now you get JP4.4.1?

As for Jupyter Install, yes there is very specific order to installing. From fresh, this is the order (At least this is what I’ve done to produce stable results):

Make sure you’ve first run all udpates:

$ sudo apt install updates && sudo apt install upgrades
  1. Install node.js using the link as discussed

  2. Install the following packages:

$ sudo apt install -y libffi-dev

And then

$ sudo apt install -y libssl1.0-dev
  1. Update / Install the following packages
$ sudo apt install python3-numpy python3-scipy python3-matplotlib
  1. Install python3-pip
$ sudo apt install -y python3.pip
  1. Install Jupyter Lab:
    First, export your path:
$ export PATH="$HOME/.local/bin:$PATH"

Next, install Jupyter this way:

$ pip3 install --user jupyterlab
  1. Configure Jupyter and set password (in case you want to run it remotely, using SSH)

To configure:

$ jupyter notebook --generate-config

Set up password:

$ jupyter notebook password

Hope that helps you with the next install.



Thanks icornejo.a

Thanks one more time, based on your recommendations I made it work.