Issues with Orin Nano Devkit and Orin NX Module


My Setup:
Orin Nano Devkit
Orin NX 16G module mounted onto devkit
Samsung PM991 NVMe SSD 256G
Host with Ubuntu 20.04 and all updates.

First issue:
brought devkit into recovery mode via button header. lsusb shows NVidia APX device, but SDK Manager says “Could not detect a board”.

I still can proceed, and flashing will start eventually.

Second Issue:

Orin NX does not support SD Card, and there is no version of this module with SD card. However, I can select “SD Card”. This is misleading and should be changed.

Third Issue:

After or duing the second part of the setup where packages get installed via ssh there is an error message regarding apt and libxmlb2. I can manually do and “apt install libxmlb2”, and this succeeds. Doing “apt install --fix-missing && pt update && apt upgrade -y” clears this message.

All three issues are repeatable and occur every time I do a reflash. I even tried a different PC with a brand new Ubuntu 20.04 install on it.

There is a fourth issue that is not totally repeatable, and I don’t know why. gnome-terminal refuses to start as user and takes a long time to start as root. Seems to be this bug:
This problem occurred repeatedly yesterday and went away magically during the last reflash.

Hi fchk,

Have you tried to use initrd flash command for Orin Nano devkit?
Quick Start — To Flash the Jetson Developer Kit Operating Software

The command line procedure did work fine. Is this the recommended way now, or am I supposed to use SDKManager. This should also work, right? I’m reporting these issues so they will be fixed.

For this issue, I could not reproduce it with Orin NX 8G+Orin Nano devkit.
It should be recognized in SDKM. Could it be recognized by SDKM after it boot up successfully into desktop?

There are some SKUs of Orin NX that have SD Card slot. Please just select NVMe in your case.

Is that error on your host PC or the board?
Second part of the setup seems installing some packages for your host PC to get prepared to flash the board.

I don’t have access to my board at this moment since a coworker needs it for performance tests. lsusb shows the board.

Great news! Can you tell me these so we can order modules with MicroSD slot.

Third issue: its on the board.

If you want the module with MicroSD slot, please order Orin Nano.
It seems no sdcard slot for Orin NX.

Then the SDCARD entry in SDKManagaer could be removed for Orin NX.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.