Issues with the occupancy analytics application

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson nano)
**• DeepStream Version 6.0.1
• JetPack Version (4.6.1)

I’m using the occupancy analytics application. When I run the make command I get the following error:

deepstream_test5_app_main.c: In function ‘meta_copy_func’:
deepstream_test5_app_main.c:314:88: error: ‘NvDsEventMsgMeta {aka struct NvDsEventMsgMeta}’ has no member named ‘source_id’
g_print(" %s %d source id: %d, Enter: %d, Exit: %d\n",func,LINE, dstMeta->source_id, dstMeta->lccum_cnt_entry, dstMeta->lccum_cnt_exit);
^~
deepstream_test5_app_main.c:314:108: error: ‘NvDsEventMsgMeta {aka struct NvDsEventMsgMeta}’ has no member named ‘lccum_cnt_entry’
g_print(" %s %d source id: %d, Enter: %d, Exit: %d\n",func,LINE, dstMeta->source_id, dstMeta->lccum_cnt_entry, dstMeta->lccum_cnt_exit);
^~
deepstream_test5_app_main.c:314:134: error: ‘NvDsEventMsgMeta {aka struct NvDsEventMsgMeta}’ has no member named ‘lccum_cnt_exit’
g_print(" %s %d source id: %d, Enter: %d, Exit: %d\n",func,LINE, dstMeta->source_id, dstMeta->lccum_cnt_entry, dstMeta->lccum_cnt_exit);
^~
deepstream_test5_app_main.c: In function ‘generate_event_msg_meta’:
deepstream_test5_app_main.c:413:9: error: ‘NvDsEventMsgMeta {aka struct NvDsEventMsgMeta}’ has no member named ‘occupancy’
meta->occupancy = obj_params->lccum_cnt;
^~
deepstream_test5_app_main.c:414:9: error: ‘NvDsEventMsgMeta {aka struct NvDsEventMsgMeta}’ has no member named ‘lccum_cnt_entry’
meta->lccum_cnt_entry = obj_params->lcc_cnt_entry;
^~
deepstream_test5_app_main.c:415:9: error: ‘NvDsEventMsgMeta {aka struct NvDsEventMsgMeta}’ has no member named ‘lccum_cnt_exit’
meta->lccum_cnt_exit = obj_params->lcc_cnt_exit ;
^~
deepstream_test5_app_main.c:416:9: error: ‘NvDsEventMsgMeta {aka struct NvDsEventMsgMeta}’ has no member named ‘source_id’
meta->source_id = obj_params->source_id;
^~
Makefile:73: recipe for target ‘deepstream_test5_app_main.o’ failed

Could you help me figure out why the app fails to make correctly?

Sorry for the late.
Seems you miss some header file.
Did this still be an issue?