Jetpack 3.2.1 OpenCV 3.3.1 python-numpy installation missing

I had to manually install python-numpy library to make OpenCV 3.3.1 work.
i think it’s installation is missing in Jetpack 3.2.1


What do you mean “make OpenCV 3.3.1 work”? Do you mean you cannot find numpy module?

import cv2 fails with numpy missing error


Does this error happen when import cv2 or import numpy? Could you share the code?

Our opencv3.3.1 in jetpack has nothing different with upstreamed opencv3.3.1.

In python shell,
I just tried
import cv2

It gave the error.
Then tried
import numpy
It didn’t work

About upstream OpenCV,
It doesn’t comes with numpy.
Python numpy installation is done manually before installing OpenCV

I tested flashing of 3.2.1 Jetpack on two Jetsons.
The numpy error is common.


As I know, our opencv from Jetpack doesn’t install cv2 for python3 but should install cv2 for python2. Anyway, I need to check this.

Thanks for sharing.

Sorry for my typo. Correct inline.

I mentioned cv2 only.

Could you try below

nvidia@tegra-ubuntu:~$ python2
Python 2.7.12 (default, Dec  4 2017, 14:50:18)
[GCC 5.4.0 20160609] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import cv2

nvidia@tegra-ubuntu:~$ python3
Python 3.5.2 (default, Nov 23 2017, 16:37:01)
[GCC 5.4.0 20160609] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import cv2
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named 'cv2'

It’s okay.
Yes I tried python 2.7 only.
Thanks a lot.

I tried.
Default python is python 2.7 in my Jetson
It doesn’t give module missing error.
It gives numpy missing error as cv2 is dependent on numpy.
So need to install that.

Could you share the log to me?

Solved the bug actually.
It’s well-known bug

ImportError: numpy.core.multiarray failed to import

In some case numpy version is also the issue.