JetPack 6.0 Developer Preview - Release Announcement

We are very pleased to announce the release of JetPack 6.0 Developer Preview (DP). JetPack 6 comes with an updated LTS Kernel 5.15 and Ubuntu 22.04 based root file system. JetPack 6 also brings in new capabilities not possible before on the NVIDIA Jetson platform for edge AI and robotics, including:

  • Flexibility to Bring Your Own Kernel: Our commitment to upstreaming Jetson changes to upstream Linux Kernel has now made it possible to bring the latest Linux Kernel on Jetson. We have provided a recipe to bring your own Kernel in our Jetson Linux Documentation. Stay tuned for further enhancements to the recipe that will make it even simpler to use moving forward.
  • Greater Choices of Linux Based Distros: Our upstreaming effort has also now enabled other Linux-based distributions to offer their operating systems on Jetson. Though Jetson Linux is the out-of-the-box Ubuntu-based distro packaged in JetPack, a number of Linux-based distributions are available from our partners. Please check the JetPack 6 Developer Preview page for details.
  • Upgradable Compute Stack: We are targeting new capabilities that will provide the flexibility to upgrade the AI compute stack and bring the latest versions without upgrading the Jetson Linux BSP. Planned for release in March 2024, this will allow AI developers to upgrade to the latest compute stack without needing to upgrade the whole JetPack. Along with the above novel features, JetPack 6 Developer Preview also packages NVIDIA Cuda 12.2,TensorRT 8.6,2, cuDNN 8.9.4 and VPI 3.0.

Visit the JetPack 6 Developer Preview page and Jetson Linux page to learn how to easily install JetPack 6.

Please Note that OTA features are not supported in this release. Please do not try to apt upgrade to JetPack 6 Developer Preview release

Please note that the JetPack 6.0 DP is a developer preview release and not intended for production. It is ready for starting your development on Jetson Orin with JetPack 6 software stack. This release does not include any security features or OTA features. The production quality release of JetPack 6.0 is targeted for March 2024 and will include security and OTA features along with production quality stack. Please carefully read the release notes of JetPack 6.0 Developer Preview for known issues and other details.

JetPack 6 Components:

  • Jetson Linux 36.2
  • CUDA 12.2
  • TensorRT 8.6.2
  • cuDNN 8.9.4
  • VPI 3.0
  • Vulkan 1.3
  • Nsight Systems 2023.4
  • Nsight Graphics 2023.3

JetPack 6 Resources:

I recently purchased a new Jetson Orin Nano dev kit from Sparkfun.com, and I am ready to install Jetpack 6.0 via the “SD Card Image Method” from my Windows 10. When I click to download the image from SD-Card-Image, there is nothing to download. It only displays a message about “… if using JetPack 6.x SD Card image for the first time, you will need to update the QSPI bootloaders by installing JetPack 6 on your SD Card using SDK Manager, which will update the QSPI bootloaders as well”. The problem is that my new Jetson Orin is blank. Will a complete working image soon be available?

Sdkmanager is running on separate x86 ubuntu PC. Not the jetson itself.

You could file your own topic.

Hi! I’ve waiting for this Jetpack for a while. I’ve already succesfully installed it but I’m having some trouble when using torch with Python 3.10.12 (default Python version). I get to install torch, torchvision and torchaudio but, when I do a torch.cuda.is_available(), I keep getting False, indicating the GPU is not accesible by torch. Also tried with Python 3.8 and got the same result. Any idea what could be going on?

CUDA version is 12.2.
Python version is 3.10.12.
torch version is 2.1.1.
torchvision version is 0.16.1.

The Jetson I’m using is a brand new NVIDIA Jetson Orin Nano Developer Kit.

Hi @jose.donate, have you installed one of the PyTorch wheels for JetPack 6 from this topic? These were built with CUDA enabled:

Given that you said your torch version is 2.1.1, and there isn’t a torch+CUDA wheel for that specific version, my guess is that you just did pip3 install torch, and the aarch64 wheels on PyPi are not built with CUDA support.

That was a good guess and an even better answer. It did work with this Docker container and with the wheel for PyTorch v2.2.0 (had to manually install numpy and packaging). Thank you for your quick and accurate response. Cheers.

I’m having the exact same problem -

@xplanescientist we will release the SD card image for JetPack 6 Developer Preview for Jetson Orin Nano today. Please note that since the QSPI bootloaders have moved to a new major version, you still will need to flash the SD Card using SDK Manager first, before using the SD Card image.

Jetson containers are live now:

L4T Base: NVIDIA L4T Base | NVIDIA NGC
CUDA (Runtime and Devel) : NVIDIA L4T CUDA | NVIDIA NGC
Tensorrt (Runtime and Devel): https://catalog.ngc.nvidia.com/orgs/nvidia/containers/l4t-tensorrt
Tensorflow: TensorFlow | NVIDIA NGC (use the tag: 23.11-tf2-py3-igpu)
Pytorch: PyTorch | NVIDIA NGC (use the tag: 23.11-py3-igpu)
JetPack: NVIDIA L4T JetPack | NVIDIA NGC

Thank you for releasing the SD card image for Jetpack 6 DP for the Orin Nano. Since I don’t have an Ubuntu linux machine, my plan is to install the image from my Windows 10 PC, then to use that SD card on my new Orin Nano and boot from there. So I’m confused why the QSPI bootloaders have to be installed. Why doesn’t the Jetpack 6 DP image already include the new bootloaders? Does this mean I can use the SD card explained above to boot the Orin Nano, then I need to install the SDK Manager on my new Orin Nano, then I install the new QSPI bootloaders? It would greatly simplify matters if the new bootloaders were simply included in the released JetPack 6 DP SD card image.

The content of QSPI(bootloader) is not able to directly got upgraded by sdcard image.

Sdcard image was never a method to full flash a board.

Can this version control GPIO?
I can’t find such path “/sys/class/gpio/export”

please refer to [36.2] problem of using gpio to control LED

Sysfs to control GPIO has been deprecated on rel-36.

Thanks, I will try it.

I am having a lot of trouble installing JetPack 6. My JetPack 5 sd card was updated, and now won’t boot. I understand that I need to get the Orin Nano into recovery mode, so I powered off, put on the jumper, and powered on. Do I leave the sd card in? Do I type any keys during boot? Then I plugged in the usb cable, but my Windows/Ubuntu box does not recognize it. Do I need any drivers or special program to recognize it? What can I do to troubleshoot it? The online instructions are very confusing.

Please file your own topic and we can discuss your issue here.

None of the above links are working. I am logged-in in NGC and Developer website.
Would it be possible to release an image of Jetson Orin NX with JetPack 6 DP?
Trying with SDK fails with many errors of USB time out, etc.
Would be so much easier and faster to just use Etcher on host and install NVMe after in the kit.

@ldec for USB timeout issue, try diabling auto-suspend and try.

sudo bash -c ‘echo -1 > /sys/module/usbcore/parameters/autosuspend’

Also ensure that you are using Ubuntu 20.04 or 22.04 based host machine.

Thank You.
Ubuntu on host complies with requirements.
Will test it and will update my post with results.