Jetson AGX xavier l4t 35.1 UEFI

I use l4t 35.1(jetpack 5.0.2) on Jetson AGX Xavier EVT kit.
The problem is UEFI boot sequence doesn’t work.

Modify the UEFI boot sequence, then save and reboot

goto “Boot Maintenance Manager”-“Boot Option”-“Change Boot Order” Then press F9and select Y

The result is the same.

Does the UEFI reset to default affect the boot sequence?

Hi Haidar007,

The F9 will reset to default.
Please press F10 to save the change and try again.

1 Like


I also tried this.
Seems F9 reset to default can work for other options,
but not for “Boot order option”.
Even tried your steps again.
The F9 will reset to default.
Please press F10 to save the change and try again.

Can you confirm whether it work?

Hi Haidar007,

Confirmed it’s working on r35.1.
From UEFI boot menu:
Change the order → Press enter and use +/- to move selection → then you can see the yellow words write “Configuration changed” → F10 to save → press Commit Changes and Exit.

Hi Carolyuu

The problem is F9 " Reset to default can work".
I don’t see you tried it in your steps.
The F9 cannot reset the boot order to a default value.

Hi neil.lee1,

If you already press F10 to save the configuration changes, F9 will reset to your change.

I think the “default” here means the one your saved. There is no record for what was flashed to the board initially.

Hi Carolyuu, WayneWWW

Thanks for your clarification! Got your point!
The default value of “boot option” comes from our saved value but not from board initial flashed value.

By the way,
can you also help clarify the F9 " Reset to default". for Auto Boot Time-out option?
When we push F9, the Auto Boot Time-out is always set as zero but not from our saved value.

Hi neil.lee1,

I can see the same result.
Our internal team will check it and update to you.