Jetson AGX Xavier USB not recognized

When I flashed the AGX, it was prompted to detect that the device is not in recovery mode. Please use “lsusb” to check whether there is NVIDIA Corp, but I am using “lsusb” to check that there is an NVIDIA Corp device.

Are you using a VM? If so, then it is not set up correctly to pass through USB (this is why it is not officially supported to use a VM…each VM manufacturer would have to provide their instructions to make sure the USB remains connected…during flash USB will disconnect and reconnect, which is when VMs fail most of the time). Is this an AGX dev kit? If so, then make sure you use the USB-C cable.

To illustrate making sure it is in recovery mode consider the recovery button a “shift key”. It is held down as either power is applied or as power is reset, then let go (the button only needs to be held down at the moment of pressing power on or power reset).

My device is AGX 32G, I use Ubuntu host instead of VM when I flash the machine, and the data of USb-typeC is also the original line given by the official. There was no such problem when I flashed the computer before. This time, we were using AGX to run DL, but suddenly the SSD hard drive could not be detected. Needs to be re-flashed. This problem was discovered during the flashing process.

The flashing process is also done according to the official tutorial.

@978766468 the message from lsusb that you have shared only indicated that the jetson is connected [ 0955:7020]
while sdkmanager pointed out that it requires not only the device connected but also in recovery mode [0955:7019]
7020[not in recovery mode]–> 7019[ recovery mode]
so while there is a detected device reflected in lsusb, the device was not in the recovery mode so that was the message from sdkmanager
once you trigger the recovery mode 7020 would change to 7019 in lsusb outputs

The methods I know to enter the recovery mode of AGX are as follows: 1. In the state of shutdown, press and hold the recovery button (REC), then press and hold the power button, and release at the same time after 2~3 seconds; 2. In the state of power-on Press and hold the recovery button (REC), then press and hold the reset button (RST), and release it after 3 to 5 seconds.The buttons are shown in the following figure. I have tried these two ways many times, but I still can’t enter the recovery mode, is there any other way to enter the recovery mode?


@978766468 you may also get into the recovery mode if you have a booted OS
then you could trigger to the recovery mode from either the console terminal or via
selecting automatic mode with specifying relevant ip address of jetson in sdkmanager interface where you selected “manual mode” as per the first image shared in your original post.

Are you using a Jetson AGX devkit? production module? or custom carrier board provider?

these methods pressume use of the recovery port of the Jetson [ only one of AGX Jetson USB-C type ports is recovery]

The AGX I’m using is a dev kit I bought from the vendor, which is what the vendor says。I will try it again according to this method。

I use the automatic setup mode, using the original IP address, I can’t connect, I can’t connect using the IP I defined myself, and I can ping through the terminal.




the error shows that it is not possible for sdkmanager to connect to the given ip addresses using provided username/ passwords via ssh.

You need to specify username/password of the jetson device, in the given window.

Does your Jetson boot? authenticate with given username/password? has the ip address 192.168.0.109?

Are you able to conenct to the ip addresses of the jetson via ssh using the specified password/username?

you may also try to connect to jetson from host pc via tty serial port [ through USB-c with sudo picocom /dev/ttyACM0] or via mini usb-b with related ttyTHS e.g minicom -D /dev/ttyUSB3 -8 -b 115200


hello, i can connect using ssh

as long as ssh connectivity does work
you should be able to use the automatic setup through the sdkmanager
but if the ssh conenctivity will not work by the moment sdkmanager is approached it won’t work
you will need to allow plain text password ssh authentication for jetson device if there are custom ssh authentication policies in place
However you may try putting the Jetson unit into the recovery mode then check with ssh if it will be still accessible it will indicate the recovery mode hasn’t triggered. Otherwise it got triggered

The problem now is that I can’t get into recovery mode when I use the official method to enter recovery mode.

I used the method you gave to force into recovery mode, but a new error message says Jetson is in a bad state and cannot be flashed.


so the good news is that you got the recovery mode state
what you may try is rebooting then repeating steps
also what is your vendor/ manufacturer? is it devkit by nvidia or production module / custom carrier board ?
It appears that you are using a custom carrier board/ or third party vendor hardware
so it may just simple lack support of sdkmanager which eventually works with default nvidia devkit AGX Jetson but doesn’t support third party vendors
but the vendor should have provided, likely own instructions for flashing
e.g. something like flash.sh method may be supported maybe with custom image etc.
try contacting the vendor support

OK, thanks

@978766468
how many RAM size does your device have?
you tried flashing it as 16/32gb module as I can see
if it doesn’t match the hardware- it is err
are you using the recovery port of your Jetson AGX?
if you are using other ports - it is err
if you are using the proper port but improper cable- it is err
it is not a complete list of errors of what can go wrong though

Uploading: 1646118687(1).png…


This should be 32G


This is when I use jtop to find that the parameters of Swap in AGX are abnormal. Will this be the main reason for the problem of my device?

What did the vendor support respond?
how was the unit flashed originally?
did it come with OS pre-installed or was flashed?