Jetson AGX Xavier Industrial Module flashing

Hi,

Is there any difference in Jetson AGX Xavier Industrial Module BSP flashing? or procedure and command is same for all the Jetson AGX Xavier Modules? (I understand that commands change upon memory in the module)

We use eMMC flashing method (flash script) with L4T32.4.3 and above for our custom BSP and custom carrier board.

hello vbhm,

you’ll need to enable the flash commands with specific flash configuration file.
please also refer to Basic Flash Script Usage for reference,
thanks

Hi thank you, will check that.

The industrial AGX Xavier Module is at customers place and they are trying to put the device in force recovery mode(on a custom carrier board) and module is not entering into force recovery mode, however they can put another non-industrial/ commercial AGX Xavier module(8GB) into recovery mode with same carrier board host PC setup. Please suggest on this.

if it enters into recovery mode then it should list as a USB device right?

hello vbhm,

correct, check $ lsusb and it should reports the device-id.

yes,
but the device is not getting listed, but if tried other modules like 8GB AGX Xavier, its getting detected/listed

hello vbhm,

please try un-plug and plug and power-supply, hold the recovery button and click the power button, then release recovery button once you see led on.

1 Like

sure we will check this and get back

The module is still not able to go into force recovery mode? Could this be some issue with module?

hi all,

please moving to the latest release,
it’s JetPack 4.6 to include the supports of Jetson AGX Xavier Industrial module.
thanks

Hi Jerry, I dont understand your reply. I was hoping you could help us with issue that the module is not going into force recovery. What does it have to do with latest release?

hello roshan.dsouza,

just double confirm you’re using good enough cable and using the host desktop with native ubuntu-OS.
you should press the key combination to put the device to enter forced-recovery mode and check $ lsusb for the device-id.

Hi Jerry,
We have checked the same setup with commercial grade module and we are able to get the commercial module into force recovery and program. The Industrial grade module we have we are not able to make it go into force recovery mode.

hello roshan.dsouza,

is this Jetson AGX Xavier Industrial module able to power-on successfully?

Hi Jerry,
The module we have is blank one. So not sure if its powering on

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

hello roshan.dsouza,

did the LED turned-on when you press power button to trigger POWER_EN?

Hi the issue still exists. We tried with dev-kit but the following error is coming.
image
The power LED is ON. So looks like the module is getting powered.

I am facing the same problem.
Would you please tell me if there is any information we should check.

Thanks.

I too am having the same issue, and did not get much assistance on my own post at Issues with flashing new industrial Xavier module - Jetson & Embedded Systems / Jetson AGX Xavier - NVIDIA Developer Forums

Any further advice for us seeing this “wrong device detected” issue would be greatly appreciated please.

Thank you.

If there are more than one guy has such issue here, can you take a picture of the carrier board sku and module sku from the sticker of the board?


Attached are images including the S/Ns for the current industrial module and AGX Xavier Developer’s Kit we have been working with.