Unable to flash the Jetson Agx Xavier(For updating the jetpack to 5.0.1) using the process given in the docs

While updating the jetpack to 5.0.1 from the older version, I was following the procedure given in docs (Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation) using the Automatic setup as it was already in working condition from older jetpack version but the during flashing the process get terminated showing some error in the terminal. Now the device is in recovery mode and can’t even be used with older version. Please provide the solution to either restore the device or to update the jetpack version from this situation.
Find the attached image for error shown in terminal

Hi ms2104102006,

Are you using the devkit or custom board of Jetson AGX Xavier.
and Are you running SDKM on a standalone Ubuntu 18.04 host PC?

Could you help to enter Force Recovery Mode and use Manual Setup to flash your board?

And please provide the full flash log and serial console log for further check.

Hi KevinFFF,
We are using the devkit as per my knowledge(Please find the images attached of the kit). Yes, we are running SDKM on a standalone Ubuntu 18.01 host PC. As the kit is recovery mode that is verified by running lsusb command on host terminal after connecting the kit via Usb-typeC cable and Its showing Nvidia corp.
I was trying initially using Automatic setup procedure mentioned in above mentioned docs during flashing it failed, then I was trying for manual setup which requires the kit in off mode connected to power supply but as soon as I connect the USB-type C cable between host then it shows the kit is detected but this should not be the case for manual setup, still I followed the remaining steps mentioned in manual setup and tried to flash it. It terminated again showing the device is in bad state.
The exported logs from the failed flashing are attached here.
Please guide me( this is my first time working on a kit ) if I am not correctly getting the right procedure for putting the kit in force recovery mode and do the manual setup for flashing.

Find the attached exported logs during failed flashing while manual setup is used
SDKM_logs_JetPack_5.0.2_(rev._1)_Linux_for_Jetson_AGX_Xavier_modules_2023-01-15_12-44-47.zip (72.1 KB)

From your image, it doesn’t look like our AGX Xavier devkit. I don’t see the buttons from the carrier board and . Where did you get this board?

Is it showed 7019 for Xavier in Force Recovery Mode? Or other value?
To Determine Whether the Developer Kit Is in Force Recovery Mode

12:56:06.969 - info: NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP@JETSON_AGX_XAVIER_TARGETS: [  11.2915 ] CPU Bootloader is not running on device.
12:56:07.022 - error: NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP@JETSON_AGX_XAVIER_TARGETS: Error: Return value 4
12:56:07.023 - info: Event: NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP@JETSON_AGX_XAVIER_TARGETS - error is: Error: Return value 4
12:56:07.023 - info: NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP@JETSON_AGX_XAVIER_TARGETS: Command tegradevflash_v2 --oem platformdetails eeprom cvb /home/anupma/nvidia/nvidia_sdk/JetPack_5.0.2_Linux_JETSON_AGX_XAVIER_TARGETS/Linux_for_Tegra/bootloader/bbd.bin
12:56:07.032 - error: NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP@JETSON_AGX_XAVIER_TARGETS: --- Error: Reading board information failed.

From your flash log from SDKM, it looks like wrong board configuration file read. If you are using the custom board, you need your vendor support for customized board related configurations because we don’t know the design of that carrier board.

Yes It is showing 7019 value, I had a talk to vendor and came to know that when this order was placed full components for AGX Xavier devkit were not available in market and they used other compactable carrier/controller board AGX Orin Carrier board RTSO-1001 (https://www.realtimesai.com/en/product/RTSO-1001.html). when the devkit was delivered they already have install the OS and jetpack inside it.
Not much of techincal support is available/expected from vendor side.Now, can you please guide me to solve this problem.
Also can you provide the list of components with specification that comes with origional Nvidia Jetson AGX xavier devkit for which all the documentation/forum support are made available by Nvidia.

Dump the log from your uart serial console. And it will tell us what happened.

I guess this issue is due to custom board. Generally, custom board requires custom BSP. If vendor does not claim they can directly flash sdkmanager, then they should provide custom bsp.

I am using the kit for very first time.It would be very helpful if you can guide me to how to get logs from UART serial console when the devkit is in recovery mode.
Thank you in advance

Hi,

Sorry that I cannot help provide precise guidance because this is custom board.

What I can share is just the method to dump log from NV developer kit as this website.

I have solved out the problem. One have to use the Custom BSP support package instead of the default one and have to use the process given here ( Quick Start — Jetson Linux<br/>Developer Guide 34.1 documentation).

Thank you very much for your help.

1 Like