Failing to flash Xavier AGX at 0.8%

Hi,

I am using Xavier AGX board and performing a first flash of the device.
My host is running Ubuntu 16.04 native OS.
So far, I am able to put the device in FORCE RECOVERY mode and detect it on my PC via lsusb command.

But when I run the sdkmanager to download and flash to AGX, I face an issue.
The flashing fails at 0.8% similar to the issue mentioned here Flashing Jetson Xavier fails - #22 by Andrey1984 . But However, I cannot use the working solution there as I cannot reinstall software/ use another machine.

How can I troubleshoot this issue?

Hi abhimanyu,

Can you please package and attach the ~/.nvsdkm directory on your host machine for more investigation?

Hi @EdwardZhou ,

PFA the tar of nvsdkm folder.
nvsdkm.tar.gz (85.8 KB)

hello abhimanyu.raju,

could you please duplicate the issue by running flash script to flash the board,
please share the messages of the failure for reference,
you may also check developer guide, Flashing and Booting the Target Device.
thanks

Hi @JerryChang ,

PFA logs while executing flash.sh script.

EDIT: Removed unrelated details from the logs
flash_script_logs.txt (819 Bytes)

hello abhimanyu.raju,

you’re not using correct command-line for flashing the board.

$ sudo ./flash.sh ${BOARD} mmcblk0p1
[sudo] password for abhimanyu.raju: 

check those flash configuration files, the naming of your target should be jetson-xavier.
thanks

Hi @JerryChang ,

I am using the board file names as shown in the table below according to the Quick start guide

The value chosen is jetson-agx-xavier-devkit . Which is also captured in the logs shared above.

echo ${BOARD}
jetson-agx-xavier-devkit

Also, I tried your suggestion of using jetson-xavier as an argument. The behavior is still the same.

hello abhimanyu.raju,

what’s the detected board-id? could you please share the flashing messages for reference,
thanks

@JerryChang , As shared in the logs, following is the detected ID

lsusb | grep NVidia
Bus 001 Device 084: ID 0955:7019 NVidia Corp.

I have shared the flashing messages in the log file above. Is there anything else you are looking for? If so, please tell me how can I find it? and I will share it with you.

hello abhimanyu.raju,

you may gather details flash messages, we need to review your flash command-line, the output flash messages, and the progress of image flashing for reference.
so,
which Jetson AGX Xavier you are working with, is it 16GB memory or 32GB memory?
thanks

hi @JerryChang ,

I am using sdk manager to download and program the Nvidia AGX devkit.
Following is the command line entry that I provide and the following response after failure.

sdkmanager --cli install --logintype devzone --product Jetson --version 4.4 --targetos Linux --target P2888-0001 --flash all --license Accept --targetimagefolder ~/projects/nvidia/sdkmanager_out/ --downloadfolder ~/projects/nvidia/sdkmanager_download/
Authenticating with NVIDIA server...
Login succeeded.
Loading user information...
User information loaded successfully.
Loading server data...
Server data loaded successfully.
Session initialized...

Installation of this software is under the terms and conditions of the license agreements located in /opt/nvidia/sdkmanager/Eula/
  ===== INSTALLATION FAILED ===== 
      - Drivers for Jetson: Up-to-date
      - File System and OS: Up-to-date
      - Device Mode Host Setup in Flash: Installed
      - Flash Jetson AGX Xavier 16GB/32GB: Failed
      - Device Mode Host Setup in Target SDK: Failed
      - DateTime Target Setup: Failed
      - CUDA Toolkit for L4T: Failed
      - cuDNN on Target: Failed
      - TensorRT on Target: Failed
      - OpenCV on Target: Failed
      - VisionWorks on Target: Failed
      - VPI on Target: Failed
      - NVIDIA Container Runtime with Docker integration (Beta): Failed
      - Multimedia API: Failed

  ===== Installation failed - Total 14 components =====
  ===== 1 succeeded, 11 failed, 2 up-to-date, 0 skipped =====

For your reference, I have shared the screenshot of the failure. The Error to Flash Jetson OS appears exactly after 0.8%

Adding Log for the same session.
sdkm-2021-03-26-11-01-07.log (200.0 KB)

The Devkit is a 32GB version

hello abhimanyu.raju,

you’re having incorrect target hardware for running a command line installation.
for example,
Flashes Jetson AGX Xavier eMMC for P2888-0001 (16 GB) or P2888-0004 (32 GB).
thanks

Hi @JerryChang ,

My bad. Changed the target hardware and executing following command

sdkmanager --cli install --logintype devzone --product Jetson --version 4.4 --targetos Linux --target P2888-0004 --flash all --license Accept --targetimagefolder ~/projects/nvidia/sdkmanager_out/ --downloadfolder ~/projects/nvidia/sdkmanager_download/

I still see the same issue of failing at 0.8% . Attaching log for your reference.
sdkm-2021-03-26-11-39-37.log (199.7 KB)

hello abhimanyu.raju,

it show an error as below,

Error: probing the target board failed.
        Make sure the target board is connected through 
        USB port and is in recovery mode.

it’s an error for probing the target board,
please put your target into forced-recovery mode for image flashing.

BTW,
there’re some package download failures, am not sure if it’s mess-up the process, have a try to delete the files and start another new command line installation.
since JetPack-4.5.1 is the latest production release, and supports all Jetson modules.
would you please also have a try with it?
thanks

Hi @JerryChang ,

As mentioned above, I can detect the device while using lsusb command. This confirms that the device is in RECOVERY MODE isn’t it?

I am using the latest JetPack-4.5.1.

I’ll delete everything and try just with installing Jetson OS alone and give it a try.

no, you’re not, the command-line you’re assign is JetPack-4.4, i.e. --product Jetson --version 4.4

Oh! I am fairly new to the Nvidia ecosystem. For some reason, I thought version referred to the Linux kernel version.
I downloaded the jetpack4.5.1 from JetPack SDK | NVIDIA Developer and downloaded and installed sdkmanager_1.4.1-7402_amd64.deb

Yet, when I give the version as 4.5.1, I get following error on command line

Jetson version 4.5.1 does not support Linux target OS on P2888-0004
Available options are:

Jetson 4.4
sdkmanager --cli uninstall --logintype devzone --product Jetson --version 4.4 --targetos Linux --host --target P2888-0004

Anything went wrong in installing?

hello abhimanyu.raju,

I haven’t check command line installation with JetPack-4.5.1,
however,
according to NVIDIA JetPack SDK, JetPack-4.5.1 is identical to JetPack-4.5 except 4.5.1 support Jetson TX2 NX module.
please try with JetPack-4.5,
I’ve installed r32.5 to one of my Xavier platform via command line installation without errors.
thanks

Hi @JerryChang,

As per your suggestion, I used the JetPack-4.5.1 this time with GUI. The result is still the same.

It is able to detect the board, but cannot flash :(

is it still shown the probing the target board failed?