Configure USB flashing port problem - when Jetson Xavier AGX reboot after completion of Flash

Hi,
I could finally flash the Jetson Xavier AGX successfully by using “%sudo ./flash.sh jetson-xavier mmcblk0p1” (other downloads were performed with SDKManager, but I couldn’t do the “flash” with it)

However, when I reboot the Jetson, I encountered the error of “Configure USB flashing port for device mode”, thus I can’t continue the further configuration when Jetson booted up with a graphic interface that requires the mouse or keyboard input through Jetson’s USB port…
I am using JetPack 4.6.1,

Any hints or solutions for this will be highly appreciated.

Are you using a custom carrier board?

No, I am using the Jetson Xavier.

Thanks

Milton Jiang

Hi,

Everyone in this forum us using Jetson Xavier. I guess you are saying that you are using AGX devkit?

Yes, the Jetson Xavier AGX.

Regards

Milton

You can try this script before doing flash, after that there is no user account/pwd configuration needed.

l4t_create_default_user.sh

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/flashing.html

After you can access the board, use uart console to dump the dmesg so that we can know why usb does not work.

BTW, I remember seeing a case somewhere that someone had similar problem with Jetson Tx2(?), and recommend to change the kernel by using :

%sudo ./flash.sh -r -k kernel-dtb jetson-xavier mmcblk0p1

And, make sure “tegra186-quill-p3310-1000-c03-00-base.dtb” or “tegra186-quill-p3310-1000-a00-00-base.dtb” is being used in the kernel.

I tried it but no difference, is it the similar case?

Thanks

Milton

If you don’t know what is dtb doing, then do not change it. Just use flash.sh with default setting and follow my suggestions to only create user name/pwd in rootfs.

BTW, what is your exact problem? I just read your comment again. Don’t really know what you want to say here.

You don’t have mouse and keyboard? or you connect them but they have no response?

I connected mouse and keyboard to AGX’s USB port, it works before I flash the AGX. But after the flashing and reboot the AGX, it reported the USB configure error and the connection got cut off.

The AGX still boot and I saw the following GUI interface which requires Mouse and/or Keyboard to continue.

I hope I addressed my problem clear now.

I will try the script you provided in previous email tomorrow, but if mouse and keyboard does not work(connected vis AGX’s USB port), it’s still a problem.

Thanks for your support.

I will let you know tomorrow.

Milton

Ok, then the guidance does not change. Need you to dump the log through UART after you can boot into the board.

By using the script of l4t_create_default_user.sh, I could bypass that user name and password creation session after Jetson AGX bootup, but the USB issue remains, I still can’t use my mouse and keyboard. My Jetson AGX doesn’t have any UART connection interface…

So our conversation here was not true? Did you really realize what I am asking here? If you don’t have a UART on your board, then it is not AGX devkit. It is a custom board.

micro-USB port, that is a serial console to debug, left-top in the following:
image

@WayneWWW asks if you have this product:

If not, it’s a custom designed board, and you should contact the vendor.

1 Like

Here are the views of my kit, Rx/Tx are in the Expansion Header ? Do you mean that I need to open the box to find them and find a way to connect to my Ubuntu host ? Please advise in a bit more details, thanks.

Hi,

If your board is not nvidia developer kit, please contact your board vendor to check how to dump uart log.

Or even how to flash the board.

If you are still not able to understand what I am trying to say, some more explanation.

  1. Your board is not NV developer kit, this is custom board from other board vendor. They use AGX Xavier module as core and the I/O board (carrier board) is made by them.

  2. Not every carrier board is able to be supported by sdkmanager. Ask the board vendor if they have their own BSP package to flash their carrier board.

I bought it from Amazon with a quite high price, how to identify whether or not it is from NV or other board vendor ?

You can refer to the document for AGX Xavier developer kit. This document lists out what our carrier board should be like. For example, we don’t have two type A usb ports on it.

So, this “NemoMaker” is not Nvidia authorized vendor ? I did realized that there are some peripheral ports location difference from what I saw on the YouTube.