Fail to flash AGX Xavier: Cannot Open USB

Hi, I’m trying to flash my Jetson AGX Xavier (32G), but keep getting the Cannot Open USB error. I have tried using the scrcipt, SDK manager, different USB cables, different host machine. But this error always show up.

For example, I tried to flash the device with JetPack 4.5.1 using, on a Ubuntu 18.04 host. Flash command used:

sudo BOARDID=2888 FAB=400 BOARDSKU=0004 BOARDREV=K.0 ./ jetson-agx-xavier-devkit mmcblk0p1

Here is the log of
flash_log.txt (58.5 KB)

And the UART log.
uart_log.txt (18.3 KB)

Thank you.

hello hawkinszhao,

is this correct board SKU? i.e. BOARDID=2888 FAB=400 BOARDSKU=0004 BOARDREV=K.0
how about remove them for running flash script?

you may check $ lsusb with the device id, please also check your device is able to enter forced-recovery mode.

Hi JerryChang,

Thank you for the updates. Removing the board info results in same flashing errors. Here is the log.

flash_log_2.txt (10.7 KB)

uart_log_2.txt (3.3 KB)

I could confirm that lsusb shows the correct recovery mode info.

Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 1532:0253 Razer USA, Ltd 
Bus 001 Device 003: ID 13d3:56d5 IMC Networks 
Bus 001 Device 002: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC
Bus 001 Device 005: ID 8087:0026 Intel Corp. 
Bus 001 Device 006: ID 0955:7019 NVidia Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

However, the device disappears during flashing. It disappears after tegrarcm_v2 --boot recovery to be exact. And every time the device reboots, the device ID will plus 1. E.g., Deivce 006 → reboot → Device 007.


Are you using a VM? This tends to fail in that manner.

Hi. I’m not using a VM. I’ve tried two host laptop devices with Ubuntu 18.04. They both fail to flash in the same manner.

hello hawkinszhao,

I’m afraid it’s usb port issue for your laptop devices, because Jetson device will connect/disconnect for several times while image flashing.

let’s narrow down the issue,

  1. did you have power-supply connected to your laptop?
  2. had you try other usb ports?
  3. you may try another good quality usb wire.
  4. please try desktop device if above approaches all failed.

Hi JerryChang,

  1. Yes, the laptop was connected to power supply.
  2. Yes, I’ve tried all the usb ports on my laptop. The flashing always fails with the same error.
  3. Yes, I’ve tried multiple cables, same error.
  4. Flashing with desktop device gives the same error.


hello hawkinszhao,

may I know how many AGX Xavier platforms you had? is it possible to replace the SOM for cross validation?

Hi, unfortunately I have only one Jetson developer kit

hello hawkinszhao,

may I know what’s the power-supply you’re used for the AGX Xavier, is it the one with 19V?

Hi. Yes, I’'m using the original 19V power supply.

hello hawkinszhao,

is this AGX Xavier ever flashed before? could you please re-download release image, for example, you may test with JetPack 4.6.2.

Hi! No this is the first time I have ever tried flashing this device.

I just tried flashing JetPack 4.6.2, got the same error.


hello hawkinszhao,

is this a developer kit? or, it’s the one with customize carrier board?
please share a snapshot of this AGX Xavier platform, please also check the serial-number, thanks

Hi. Yes, it is a developer kit. I have attached two photos of this device. You can find the serial-number on the second photo. Thanks.

hello hawkinszhao,

it’s usb-c cable for image flashing, when running SDKManager, it will provide your developer kit with an Internet connection via this USB connection.
you may reading Jetson AGX Xavier Developer Kit User Guide again, please follow the instructions to setup connections.

Hi. I was following the guide and using the USB-C port in the front for flashing. But I got the error above. Thanks.

hello hawkinszhao,

I cannot think of any erroneous software steps, it might be hardware issue,
hence, please go ahead to contact the NVIDIA Customer Care team and submit RMA process.

Hi. Thank you for the updates. Unfortunately the warranty of this AGX Xavier device is expired. Is there any other things I could try?

just curious, you never flash this device before??