AGX Xavier flash with Jetpack ends but never boots

Hi all, I’ve been trying to flash a Jetson AGX Xavier for a week and I haven’t been able to solve the issue. I’ve tried flashing from the sdkmanager 4.6, 4.5.1, 4.5, 4,4,1 and 4.4. I tried from my PC (using both ethernet to the pc and the board) and from my laptop (wifi from the laptop and ethernet to the board).

In both cases everything works fine until the flashing finishes “succesfully” or that says the SDK’s terminal and the nightmare begins. I realized that when flashing from my PC it jumps from around 70% to finished, in my laptop that didn’t happen and I thought it could be the source of the problem but it still failed from the laptop.

Here you can see what happens:

Unfortunately I don’t have a way to copy the full log from the Jetson but it seemed like the main errors come from the CPU’s and the main stuff I could make sense of were a kernel BUG at /dvs/git/dirty… tegra_cbb.c:839!. Also several errors like CPU0: Error :CBB-NOC, BPMP-NOC…

I’ve searched online and I have no clue what is going on, the Jetson was given to me by my university so it probably has been used (externally looks in perfect shape and quite new). I’ve already lost a lot of time so I’ve you think of anything I could try, please, answer me ASAP.

Thanks in advance, if you need to see the output of the Jetson with more detail, let me know!

hello pablo_rocasg97 ,

could you please put your Jetson AGX Xavier enter forced-recovery mode, and enable $ lsusb to check the device number.
you shall see this message, Bus <bbb> Device <ddd>: ID 0955: <nnnn> Nvidia Corp.
which contain the numbers that represents the type of Jetson module, please also share that for reference,

Hello Jerry, thanks for the fast reply. This is the information:
Bus 003 Device 015: ID 0955:7019 NVidia Corp.

Hello again, another Xavier user has told me that he had some installation issues when using a usb cable that wasn’t the original. I’m not completely sure the one I’ve used is the original as the board has been used (it is thicker than typical usb smartphone cables), is there any specifications the usb cable needs to correctly flash the jetson? Do you think it could be related? I tried flashing with another cable I had and same issue. I don’t think this is the problem but just in case it could be.

hello pablo_rocasg97,

it’s Jetson AGX Xavier series,
could you please confirm it is the module with 16GB or 32GB memory, or it is an industrial module?

please try execute flash script manually, you’ll see under JetPack installation path.
for example, ~/nvidia/nvidia_sdk/JetPack_<version>_Linux_<platform>/Linux_for_Tegra/

you should assign correct flash configuration file to flash the target.
here’s developer guide for your reference, Basic Flash Script Usage.

Hello Jerry, it was the 32GB version. I’ve been able to replace it for another one but I’ll let the owner know that he can try this. Thanks a lot for your help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.