Jetson AGX Xavier Not Booting, fails to reflash through SDKmanager

Apologies if this is a bit of a broad subject, but I’m currently out of ideas.

Previously, I had attempted to install Alphafold through the Jetson onto an external hard drive. Though this process was extremely slow (I suspect some combination of the size of the install and the write speed of the hard drive). Our lab decided to cancel the install and delete the installed files. This made the Jetson extremely slow, necessitating that it be powered down. Afterwards however, it has consistently failed to boot, getting to the initial Nvidia logo, transitioning to a black screen, and never showing the desktop.
I’ve done the following to fix/get error reports.

  1. Reflash with SDKmanager. Jetpack 4.6.1 continuously fails to reflash, giving the attached error report.SDKM_logs_JetPack_4.6_(rev.1) (186.7 KB)

  2. Serial Debug, according to (Setting up a serial console for debug). However, while the board is visible on host lsusb, I am unable to connect to the console over gtkterm. I’ve tried ttyUSB0, ttyUSB1, ttyUSB2, ttyUSB3 across several baud rates. (783.4 KB)

Any advice or insights would be greatly appreciated.

Thank you very much


Can you directly put the board into recovery mode and use under your ~/nvidia to flash the board?

If you hit any error, please attach the log.

Hi Wayne,

I’m able to access ~/nvidia, but I see there are a number of options for Could you offer any guidance on what options I should select?

Thank you very much,


Please refer to the quick start guide in download center.

I think, you should add the rootdev in your flashing script too. Can you try this?
sudo ./ jetson-agx-xavier-devkit mmcblk0p1

Other storage types are detailed here:


[quote=“mehmetdeniz, post:6, topic:189325”]
sudo ./ jetson-agx-xavier-devkit mmcblk0p1


Thanks! I tried sudo ./ jetson-agx-xavier-devkit mmcblk0p1 and got the attached screenshot. The Jetson was in recovery mode per NVIDIA Jetson AGX Xavier Developer Kit Initial Setup - YouTube. When checking the sdk manager and trying to reflash, I had more of the failed component errors as before (see attached screenshot).

As I have time, I’ll read through the options and update if I find anything.




If you are talking about the flash problem, please just use and resolve the recovery mode problem first…
Looks like the board is not in recovery mode at all. Or you just use the wrong type C usb port…

You can just ignore the error from SDKM GUI. They are not related to your problem now.

Also, you don’t need to read any options in They are not related to your problem either… what your problem here is just failing to put the board into recovery mode…


Getting into recovery mode is definitely the issue. Per the dev kit setup video, and this forum Recovery mode does not work(Jetson AGX Xavier), the board should be set in recovery mode. I was able to measure noisy voltages across the recovery button (per the linked forum discussion).

Upon trying to use SDK manager, I get the attached error message

Looking into that bashscript and running /, I get the following

. Confirming that the Jetson is not in recovery mode.

Just running ~/nvidia/nvidia_sdk/JetPack_4.6_Linux_JETSON_AGX_XAVIER_TARGETS/Linux_for_Tegra$ sudo ./ gave the following error

I noticed an option, rcm-boot. However, when trying to run this option I get the following issue.

Any advice or suggestions would be greatly appreciated.




The only command you need to run is

“sudo ./ jetson-agx-xavier-devkit mmcblk0p1”

My point was you shouldn’t need to add or change anything here. For example, no need to add --rcm-boot. Just follow the same command as I said here.

And share us the result of this command if you hit error.

According to your previous result, it just says your board is not in recovery mode.

Please make sure that you are using a x64 ubuntu 18.04 host and non VM.


Thanks for the quick reply. I ran sudo ./ jetson-agx-xavier-devkit mmcblk0p1 with the following results. The Jetson was set in recovery mode to according to the previously linked video and upon, failure, was repeated with the Jetson set in recovery mode according to the previously linked forum post.

I’m using Ubuntu 18.04.06 x86_64.

Thank you very much

If this is new to you, please make sure the type C usb cable is to J512 port… only this port can get flashed.

Also, when the board is in recovery mode, you shall see nvidia corp in “lsusb” on your host, and there should be no OS running on jetson… which means you shouldn’t see anything on the monitor, console of jetson AGX…