Unable to Flash Jetson AGX Xavier Platform

Hello, i have problem with flashing my jetson xavier agx platform while trying to upgrade jetpack system. During flash i get the error implying that platform is not in recovery-mode even though I put it in recovery mode.

Platform OS: jetpack 4.5.1
Host OS: ubuntu 20.04

I do following steps:

  1. Turning off platform and unplugging AC
  2. Connecting to host by USB-C
  3. Plugging the AC
  4. Pressing and holding down the Force Recovery button.
  5. Pressing and holding down the Power button.
  6. Release both buttons.

After doing following steps, the sdkm is showing following massages:

When it comes to flashing options in sdkm, I choose Manual Setup option. After thath sdkm gives me following error:

Full log:
log.txt (6.7 KB)

Thing i’ve tried:

  1. Checking if host sees device in recovery mode:

  2. Runnig flashing script manually:

  3. Entering recovery mode by terminal and logging serial console:
    On platform running: sudo reboot forced-recovery
    After a while, platform shows up in sdkm as before but i getting same errors.
    Serial console output:

  4. Updating without flashing
    While updating, when flashing options are presented i clicked “skip” but this path also ended up with errors.

For the 4.x JetPack/SDKM release you should try using a host PC with Ubuntu 18.04. I don’t know if 20.04 is the problem or not, but this might be.

Additionally, you said holding down and releasing the power button. Do you mean the power reset button? The actual power button only works for this if the power starts in the off, you hold recovery, and then start power. If you really meant the power reset button, then that should work.

As linuxdev mentioned, the 4.x JetPack/SDKM release can’t support on Ubuntu 20.04.
Please try with a host PC with Ubuntu 18.04.

@linuxdev @kayccc thanks for replies. I tried same things on ubuntu 18.04 and I still get the same problem.

When it comes to buttons i follow instructions from skd manager and user gide:

What you did looks basically correct. The lsusb shows it sees the Jetson. Technically that lsusb could be from fully booted, but it seems unlikely. Can you see what the serial console shows from the AGX if you start logging from power off and bring it up in recovery mode? I’m curious if logging confirms it is not a normal boot.

I guess its weird but when I boot into recovery mode i get nothing in serial console. Only when I do normal boot, serial console shows some logs. Should i get logs in serial console when i booot into recovery mode?

when I try to boot into recovery via “sudo reboot forced-recovery”, serial console freezes on such logs:

My main goal was to see that boot was not ordinary, which would log. Certainly there is output during a flash, but on my AGX I don’t see any serial console output when starting in recovery mode. I think the output you see from software-based reboot to recovery is what I’d expect. Under the circumstances I’d say the Jetson did attempt to go into recovery mode, and was not accidentally booted normally (e.g., if the recovery button had failed). So it is a mystery to me now how the Jetson does not show up with “lsusb -d 0955:7019”. If you can verify that the lsusb fails even though it is otherwise in recovery mode, then I think you have a failure in need of RMA. If lsusb shows up, but only the host PC flash fails, then it might just be a cable or signal issue.

jetson does show up in “lsusb -d 0955:7019” after recovery boot, only flashing fails. When it comes to cable, i also tried to flash with brand new cable from agx orin.

I will suggest attempting to flash on command line from the “Linux_for_Tegra/” subdirectory. For an AGX Xavier dev kit:
sudo ./flash.sh jetson-agx-xavier-devkit mmcblk0p1

You might choose to instead log the flash:
sudo ./flash.sh jetson-agx-xavier-devkit mmcblk0p1 2>&1 | tee log_flash.txt

If it is a quirk of JetPack/SDKM, then command line would eliminate that. It would be a good test of finding where flash fails.

I have been trying to flash jetson also by ./flash script.

Screens from this attempts are shown in this comment:

It would be far better to stick to a single thread. Also, screenshots are problematic at times since they can’t be searched or put in an editor, so actual flash logs are a better choice (they can also be attached to the forum thread).

In general though, often the use of a VM is the cause of not detecting the Jetson. If this is a VM, then you should try an actual host PC (a VM can work if USB is configured correctly, but that is the realm of the VM docs).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.