Cannot flash a new jetpack with the SDK Manager to a brand-new out-of-the-box Jetson AGX Xavier with JetPack 4.3 flashed on it by default


For the past few days I have been trying to flash the latest JetPack 4.6.1 on a brand-new out-of-the box Jetson AGX Xavier development kitusing the SDK manager and nothing I do seems to be working.

Firstly I tried flashing it by putting the AGX into recovery mode manually, assuming that it did not come with a JetPacked version flashed on it by default. When I tried doing that, although the SDK manager was recognizing the Jetson being connect to my host machine running Ubuntu 18.04 and it was saying it was in recovery mode, whenever trying to attemp the flashing it just said that the target is in a bad state. While doing this lsusb command on the host machine indeed showed an NVIDIA corp device connected to it and since the Jetson was the only such device I assume it was that but the SDK manager still always reported that the target was in a bad state.

Maybe I should have tried this from the beginning but after those first attempts, I just tried booting into the Jetson and to my surprise it booted into it and prompted me to finish the initial setup by choosing a new username and password. I did that and then at first boot-up I already saw during the booting screen that some service fails to start properly. I did not give too much attention to this and went ahead and checked the L4T version it had pre-packaged and the command cat /etc/nv_tegra_release reported L4T Version R32.3.1, which corrsponds to jetPack 4.3.

Seeing that there was a JetPack already running on the AGX, I went back to the SDK manager on the host machine and proceeded to try and flash the new Jetpack with the “Automatic Setup” option, by detecting the IP of the running Jetson over USB. When I tried doing that, if I tried it with the AGX running and booted into the default JetPack, I always got the error “Not exactly one NVIDIA Jetson device is connected with USB. For using default IPv4 address, please connect exactly one Jetson device. This can be validated by running the ‘lsusb’ command on your host, and look for (NVIDIA Corp).”. Running the lsusb command did not show any “Nvidia Corp” devices connected over USB. I also tried doing this with the AGX in recovery mode and it just reported that “no such IP address has been found”.

To furtherly elaborate on the error I got when trying to flash it with the AGX running, I went and I checked eventually what was the service that failed during the boot up and it was the “nv-l4t-usb-device-mode.service”. From what I understood this service is the one that enables the Jetson to be seen as a USB mass storage device. I ran also the command described in this post and got exactly the same result as this user got. I also checked the accepted answer on that thread and it says to try and apply a kernel patch to the AGX but I do not have too much experience with that and I am sure there must be another way to deal with this.

Please let me know what can I do in order to get around this issue and be able tu succesfuly flash the new JetPack 4.6.1 on my brand new AGX Xavier!

Thank you!

FYI, any previous software flash will have no effect on the recovery mode. Recovery mode is independent and should always be possible, and the result of flashing will never change due to any previous release (though it is useful information to know what worked previously).

Is this a stock development kit? Or does it use a third party carrier board? If the latter, then it needs a custom device tree provided by the carrier board manufacturer.

If this is a stock dev kit, then you need to provide a full serial console boot log to see exactly what went wrong.

Assuming that the host PC (not a VM) has correct software installed on it for flash (sometimes the installed software can be corrupt and it becomes useful to reinstall it), then I suggest a command line flash along with creating a log and posting the log here:
sudo ./ jetson-xavier mmcblk0p1 2>&1 | tee log_flash.txt
(then attach “log_flash.txt”)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.