Not exactly one NVIDIA Jetson device is connected with USB. For using default ipv4 address, Please connect exactly one Jetson device

I am trying to install NVIDIA Jetpack 4.5.1 on Linux 16.04 Host system .When SDK Manager is about to flash our Jetson AGX Xavier module USB is not detecting.
Please suggest required solution.

Hi akanksha.wagh,

Are you using the devkit or custom board?

Could you help to run lsusb on you host PC and share the result here?

Hi , I am using devkit .

I can’t see any NVIDIA Jetson device on your USB bus.

Could you help to connect the AGX Xavier devkit with both TypeC port (for flash) and Micro-USB port (for serial console log)?
and please enter into force recovery state first. (by pressing RECOVERY button before giving the power)

Hi Kevin , I tried this solution but still facing the same issue.
what else I can do?

Are you using standalone Ubuntu16.04 as your host PC? Or something else like VM/docker/WSL2?

Your host PC should recognize the board first.
You may refer to the following thread for force recovery state.
Force Recovery Mode of Jetson Xavier Series - Jetson & Embedded Systems / Jetson AGX Xavier - NVIDIA Developer Forums

I am using standalone Ubuntu 16.04 as my host PC.
I have referred this thread and tried both the ways for recovery state but there is no change happened.

Have you change other USB ports on the host PC?
Is there any light on the devkit at this moment?

Please make sure your jetson is booting up first. The device mode will only work when it boots it kernel.

Yes,I have tried with type C USB .
Two LED’s blinking on the board.

Jestson board is not booting .

Then there is no need to test with device mode. Just skip that part in your sdkmanager.


Also, the picture you showed indicate it is not jetson devkit. Which means it has chance the software configuration is not correct from the beginning so device mode won’t work.

Can you please suggest procedure to install Jetpack 4.5.1 for this board?


Actually the whole flow is like this

if you are just a end user, which means you are not making any custom carrier board.

  1. If you are using devkit, then you can use sdkmanager to flash the board.
  2. if you are not using NV devkit, then you need contact the board vendor to get their customized BSP

if you are a custom board vendor, then you need to follow the document to modify the kernel/pinmux and device tree to make usb work.

Thus, I cannot directly answer your question. If you insist on using usb device mode, then need to answer above first.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.