SDK Manager running on Ubuntu 20.04 (WSL 2) unable to detect Jetson AGX Xavier device during Flash stage

Hi, I am trying to flash the Jetson AGX Xavier Devkit using Ubuntu 20.04 running on WSL2 . During the flashing stage, I chose the Manual Setup option and followed the steps to put the device into Force Recovery Mode. I then attached the BUS ID of the Jetson device to the WSL Linux distribution. The attach appears to be successful but the terminal on the SDK Manager throws an error saying it could not detect correct NVIDIA Jetson device. If I try to run the command to attach again, it says the device has already been attached to a client.

I’m relatively new to this, so any assistance or guidance would be very helpful.

Thank you

  1. Does lsusb in WSL show the board?
  2. you can try sdkmanager --list-connected to see if it detects the board
  3. you can also try the script in the install dir to do the flashing manually, it allows you to set the usb-port
  4. try a non-VM approach aka bare-metal ubuntu (20.04 or 18.04, preferably 18.04), if possible

Thanks a lot for the response.

Yes, lsusb is showing the board.
sdkmanager --list-connected all also shows the board and confirms that the device is in Recovery mode.

If I put the device into recovery mode and attach the respective BUS ID before running the SDK manager, the SDKM is able to detect the device and tries to flash it.
However, while flashing it runs into an error saying the target is in a bad state and asks me to manually put it into recovery mode.

I had followed these steps to put into recovery mode -

  1. Power off the device.
  2. Press and hold the force recovery button (middle)
  3. Press and release the power button
  4. Release the force recovery button after few seconds

Is there any other way to put it into recovery mode?

I also tried to manually flash the board following the steps provided here:

I’m running into an error when I run sudo ./

As a result the flash command also fails showing No such file or directory for a bunch of things.
Nvidia_AGX_Xavier_manual_flash_log.txt (13.5 KB)

Any suggestions on how to proceed using either of the methods would be very useful.
Please let me know if any other information is required.

Don’t put the BSP in a Windows partition.
It brings a lot of permission issues.

Oh okay, thank you for the information.

In older versions of usbipd it was necessary to use the -a option as well. makes the Jetson disconnect from the host for a short second, and usbipd did not automatically reattach the bus. Current versions of usbipd do this automatically.

1 Like

Okay, thanks for the information.
I have the latest version of usbipd (4.1.0) so I think the automatic reattachment does happen.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.