JetPack 4.2 sdk installation failed - cannot find NVIDIA device connected to USB

Hi, I am trying to setting up my Xavier using JetPack 4.2 sdk manager. I have followed the instructions to finish “System configuration wizard” and successfully logged into desktop of my Xavier. However, when I typed in the username and password on my host PC, I got a “could not detect NVIDIA Jetson device connected to USB” error.

I tried “lsusb” command in the terminal but it doesn’t show “NVIDIA Corp.” devices. It is weird because “lsusb” command listed “NVIDIA Corp.” before the OS was installed, but disappeared upon completion of OS installation.

Can I possibly get some help on this issue? Thanks a lot in advance.

Host PC spec:
CPU: i5-3470
RAM: 32 GB
OS: Ubuntu 16.04

Hi tianqi.xu,

After flashing and Jetson device booting up, usb-device mode is up.
The expected results at this stage are:
Jetson device: 192.168.55.1
Host machine: 192.168.55.100

You can check detail information from here: https://devtalk.nvidia.com/default/topic/1050477

Hi carolyuu, thank you for your reply and it is very helpful.

It looks like the problem is that Ethernet over USB on my host PC side is not set up properly.
I viewed “dmesg --follow” log and the terminal doesn’t show anything when I plug and unplug the cable.

Is the original TypeC USB cable that comes with the developer kit necessary to set up Xavier?
I’m asking because I’m currently using a general TypeC cable that I use to charge my phone. I borrowed Xavier developer kit from one of my friends and he didn’t include the cable in it.

I tested with the original USB Type C cable and Xavier is now recognised. Thank you!

Hi tianqi.xu,

Good to know is working now :)

I was facing similar issue and I could manage flashing manually. I just cd to nvidia directory and executed the program flash.sh and it worked as a charm. Not sure why the manager dashboard simply does not recognize my xavier device.
Cheers.

Hi carlosrl,

Please try using eth0 ip address to install sdk components.

Hi carolyuu, the SDK Manager was failing to flash the target. Then I just got to command line, did flash manually and it worked fine. Then I went back to SDK manager, skipped the flash step and and components installed with no problems. I did all these steps without make any change in the Xavier device. It seems that the flash task from SDK Manager must be reviewed (or removed) to avoid the Nvidia user waste time trying make it flash the device with no success. I remember I had a similar problem with TX2 as well.
Cheers.

Hi carlosrl,

Good to known you can flash and install sdk components successfully.
For flash task, you can put your device into recovery mode first and select manually to start sdkmanager flash. It’s working fine.

Hi carolyuu, I tried to use sdkmanager, in auto and manual mode, to flash the target device and both failed after many tries. But I could manage the flash step running some command line in a terminal.
Chees.