Cannot Flash SDK from SDK Manager


I have a new NVIDIA Jetson AGX Xavier and I am following the JETSON AGX Xavier User Guild to download JetPack 4.4 and install the SDK.

However, I received connection error and I cannot install the SDK. The farther step that I can go is “Flash Jetson OS”. When the SDK Manager attempts to flash Jetson SDK Component, I kept receiving a message “Cannot connect to the device via SSH. Validate that SSH service is running on the device”.

I try to install JetPack 4.2.3, but I receive the same type of error.

Can you please suggestion possible solutions?


Hi kyehliu,

Are you connect flash cable (type-C to type-A) from Xavier to host machine?
Please connect flash cable and using ‘ifconfig’ to make sure you can see “” ip address on your target.
You can also try using eth0 IP address instead of USB IP address (


Yes, I connected flash cable (type-C to type-A) from Xavier to host machine.

I cannot boot the target. I saw some text on the screen but it did not get me into the login menu, so I cannot confirm as you said. However, I can ping from my host PC and see normal result.

Can you please explain how I can try using eth0 IP address instead of USB IP address (

Hi kyehliu,

Please connect HDMI monitor to do first boot up initial process setup.
Wait device boot to Desktop GUI, then start install sdk components.


The screenshot says 'cannot connect AGX Xavier with acount nvidia:nvidia'.
You should connect a HDMI monitor and a keyboard/mouse to the Jetson AGX Xavier for the first boot-up step.
In the step you would meet EULA, account generation, locale info.
After this initial jobs, SDK manager of host pc can step forward, install remain stuffs.


1 Like

MtHiker, carolyuu,

This issue is resolved. Thank you!

I had missed the step of going to the screen of Jetson AGX Xavier to set up my account and password. After I configured my account, I was able to install the other SDK packages such as CUDA and completed without errors.

I did not need to configure any IP address manually. The default IPs worked out fine.

Meanwhile, I first connected Jetson AGX Xavier by HDMI/VGA cable to a monitor but it could not work. I saw some text one the screen but it stuck and not entered the Linux configuration menu. That is why I was not aware of the account configuration step at the first place and mistakenly thought I could use nvidia/nvidia for both account and password. After reading your reply and check another post , I tried HDMI/DVI cable with a newer and larger monitor and it worked.

I need to clarify that my HDMI/VGA cable and monitor is not faulty and I have been using it for Jetson Nano. It just cannot work with Jetson AGX Xavier. If I had used the HDMI/DVI cable with that larger monitor at the first place, I probably would not have encountered this issue.