Unable to install SDK components on Jetson AGX Xavier Devkit

Hi,
I have two issues on the devkit,

1.Not able to use serial console on AGX Xavier Devkit
2.Recovery Mode- lsusb reports the nvidia connected, but no ip 192.168.55.1 reachable

1.I have connected J501 Micro USB to my Windows Teraterm/Putty (Also tried it on Linux host machine via Minicom), see attached picture. I am not seing any ttyUSB device in the host machine nor the console messages. What needs to be done to get the serial console to work in devkit?

  1. with the same dekit I tried to install SDK components using SDK Manager(My devkit has working nvidia stock BSP in the 16GB module)

->put the devkit in force recovery mode
->Connect the USB cable from Linux host computer to the front USB
Type-C(J512) connector on the developer kit
->check the devkit is in recovery mode using lsusb in host - Nvidia corp usb device listed
->open SDK manager and try to flash the components

proceed further to flash, I get below error:
The error shown is :
Could not connect to the target device.
(attached picture)

I am not able to ping or ssh 192.168.55.1 . Nor I see readme file in the auto-mounted “L4T-README” folder for more details, as i dont see L4T device mounted in host PC.

  1. Is it possible to check the IP address of the devkit while it is in force recovery mode? (I followed this link and they shared the devkits ifconfig details, but dont know how : Unable to install SDK components post flashing my Jetson TX2 module - #11 by olasalte)

I have attached dmesg log from my ubuntu 18.04 host machine, which says
[361994.367521] audit: type=1400 audit(1627031485.714:69): apparmor=“DENIED” operation=“open” profile="/sbin/dhclient" name="/usr/local/ssl/lib/libcrypto.so.1.1" pid=31303 comm=“dhclient” requested_mask=“r” denied_mask=“r” fsuid=0 ouid=0

I have tried to follow below discissuin but no help:




dmesg-follow_host.txt (71.8 KB)

Please suggest on these issues.

Backing up a bit to explain some things about the flash procedure…

If the system is already up and running, then you do not need to flash again. You could just fully boot the AGX without recovery mode, uncheck flash in the SDKM on the host PC, and if networking is available, add components.

If you do flash, then you also need to complete first boot setup (the unit automatically reboots after flash completes). Since ssh is used for extra component install the first boot setup occurring first is mandatory…ssh won’t have an account to use if not.

When an AGX is booted the USB-C connector provides a virtual wired ethernet device (it has to be the USB-C connector). Your host PC would normally just show that device when the USB is connected to a fully booted AGX. However, each host has the possibility of being set to not make use of any random network device unless the end user confirms it is ok to use this device…not all hosts will allow this without you telling the host PC to allow this.

You have to be in Linux (and not Windows) if you were flashing, so to find out more about whether virtual wired USB ethernet was created, monitor (from the host PC) “dmesg --follow”. Then unplug and replug the USB-C. This should result in log messages which you can post here. Also, from the host PC, post the output of “ifconfig”. We should be able to see if the device is visible, and then decide if it is just a case of the host PC needing to have the user say it is ok to use this device.

Keep in mind that when packages are added or modified via SDKM over ssh that the address 192.168.55.1" is just a default. If your AGX and host are on the same router via the wired ethernet (not the virtual over USB), and if you know the IP address of the Jetson, then you could just change the default from 192.168.55.1 to whatever your current wired ethernet address is. You’d know about this from running “ifconfig” directly on the fully booted AGX.

I’m having a similar issue.

My Xavier is flashed correctly with JP4.6. It boots up, and I pass the ‘system configuration’ screen.
Xavier developer kit is connected to the Host using usb-c (J512), and ‘lsusb’ on the Host yields:
Bus 001 Device 011: ID 0955:7020 NVidia Corp.

I set up my host “ethernet over usb” to 192.168.55.2 and the Xavier’s ‘ltbr0’ is 192.168.55.1.
I’m able to SSH from the Host to the Xavier.

SDK manager is still unable to complete SDK component installation on Xavier.

It seems SDK Manager fails on: ip addr | grep 192.168.55.1.
On my configuration ip addr | grep 192.168.55.1 is empty but ip addr | grep 192.168.55.2 is full.
Can you assist?

Terminal output
14:21:25 DEBUG: running command < [ lsusb | grep -c "0955:" -ne 1 ] >

14:21:25 DEBUG: command terminated with error

14:21:25 INFO: Only one NVIDIA device detected, as expected.

14:21:25 INFO: Start to check if ip and ssh up with default ip…

14:21:25 DEBUG: running command < true >

14:21:25 INFO: command finished successfully

14:21:25 DEBUG: running command < ip addr | grep 192.168.55.1 >

14:21:25 DEBUG: command terminated with error

14:21:25 ERROR: Could not connect to the target device. Verify that: 1. The device is connected to this host machine with a USB cable. 2. Ubuntu ‘System configuration wizard’ is completed on the device. 3. Jetson’s Ubuntu OS is up and running. 4. Jetson USB device mode service is started successfully. * See readme file in the auto-mounted “L4T-README” folder for more details.

14:26:11 SUMMARY: NVIDIA Nsight Systems - host: Install completed successfully.

14:28:27 SUMMARY: VisionWorks on Host - host: First Error: Failed to install debian package for apt issues, requires manual fix [host]. SDK Manager received errors while using apt commands on your system. Please check that the Ubuntu local apt repository is working well on your local system including dependencies of packages. Review SDK Manager terminal for the specific error/s.

14:21:25 DEBUG: running command < [ lsusb | grep -c "0955:" -ne 1 ] >

14:21:25 DEBUG: command terminated with error

14:21:25 INFO: Only one NVIDIA device detected, as expected.

14:21:25 INFO: Start to check if ip and ssh up with default ip…

14:21:25 DEBUG: running command < true >

14:21:25 INFO: command finished successfully

14:21:25 DEBUG: running command < ip addr | grep 192.168.55.1 >

14:21:25 DEBUG: command terminated with error

14:21:25 ERROR: Could not connect to the target device. Verify that: 1. The device is connected to this host machine with a USB cable. 2. Ubuntu ‘System configuration wizard’ is completed on the device. 3. Jetson’s Ubuntu OS is up and running. 4. Jetson USB device mode service is started successfully. * See readme file in the auto-mounted “L4T-README” folder for more details.

14:26:11 SUMMARY: NVIDIA Nsight Systems - host: Install completed successfully.

14:28:27 SUMMARY: VisionWorks on Host - host: First Error: Failed to install debian package for apt issues, requires manual fix [host]. SDK Manager received errors while using apt commands on your system. Please check that the Ubuntu local apt repository is working well on your local system including dependencies of packages. Review SDK Manager terminal for the specific error/s.

This should probably be a new topic, but I am surprised the above worked since the host’s IP should be “192.168.55.100”. Manual intervention would be needed to change this to “192.168.55.2”. On the other hand, if you can ssh from the host PC to the Jetson at 192.168.55.1, then it should be ok. Host PC side should be 192.168.55.100, while the Jetson should be at 192.168.55.1.

Note that sometimes the host PC needs to be told to allow the virtual USB wired ethernet, e.g., via marking the MAC address ok to use in something like “nm-connection-editor” (if you don’t have this, then you can “sudo apt-get install network-manager-gnome”). If you monitor “dmesg --follow” on your host PC, and then insert the USB cable from the Jetson, it should tell you the MAC address to enable. Once enabled, then the host should show 192.168.55.100 as one of its addresses, and ping of 192.168.55.1 should start working.