How to install jetson SDK components after flash jetson os image


I haved used Jetson SDK to flash my AGX Xavier kit. To save time, I didn’t install Jetson SDK Components at the first time.

Now I want to try other SDK components, e.g. CUDA, DeepStream etc. How should I install these components?

I tried to do the same steps as before. In the SDK, under “TARGET COMPONENTS”, I uncheck “Jetson OS”, and check “Jetson SDK Components”, but the progress stuck in 33.33% in second bar, and the device never boot up, so it can’t go next to install SDK components.

Note: as I already setup my kit for developement, so I don’t want to refresh kit.

Please help to advise.



Hi @lr75021 ,

We have encountered similar problem which you have. How did you connect to sdk manager? We have used ssh with user name and IP instead of “” and it solved. I wish you could solve it with same way.

What @ozguryildiz said is especially true if your host PC is using a VM. VMs often cause such failures.

hi @ozguryildiz @linuxdev,

Thanks for your feedback.

I am using Ubuntu host PC, not VM. I find the problem might be AGX itself, as when I run lsusb in host, I can’t find “NVidia Corp.” in device list. That is why I can’t find the device “” from sdk.
Note: if I boot device from factory recover, then I can see the device from lsusb. But I don’t want to refresh the device.

I tried the same host pc with an NX xiavier dev kit, and it is working.

Does anyone know how to fix the USB issue in AGX?



I setup another AGX dev kit and it works fine. I can see Nvida as device from lsusb, and see a drive name called “L4T_README”. I can also ping “”. Its Jetpack release version is R32.5.1.

For the one with issue, its release version is R32.3.1. Is it the release version issue? How can I get the device USB working?

Please help to advise.



Note that for the AGX Xavier dev kit the correct USB connector is the USB-C near the corner where the buttons are. If you use another connector, then there won’t be an Xavier shown from lsusb even if in recovery mode. If you are definitely in recovery mode (recovery button held while either powering on or cycling power, then recovery button let go), then it is likely a hardware problem (but do check the USB-C cable as this is part of the hardware).

hi @linuxdev

I use same USB-C cable for testing, one is working, the other can’t show the Nvidia device. If I use factory recovery mode, I can find it from lsusb.



While USB-C is connected, and the Jetson is in recovery mode, the Xavier can be flashed. Extra software packages can only be installed on a fully booted system which has completed the first boot account setup…recovery mode won’t allow this, it is purely for flashing. Normally a flash completes and the Xavier reboots automatically.

Once a correctly flashed Jetson is rebooted and the USB is connected it should be possible to see the Jetson as a network device (not useful unless (A) the host PC allows the connection to be used, and (B) the first boot setup has added your user to be used with ssh).

Host PCs are not always set to blindly allow USB network devices to be used. If you monitor logs via “dmesg --follow”, and then connect the USB cable, then if the Xavier offers to become a network device, there will be a log message which lists the MAC address of the Xavier. It is that MAC address you would use with system tools to tell the host PC to allow this (most systems by default allow this, but there are a number of systems which require manually enabling). Does “dmesg --follow” show anything with a MAC address when plugging in the USB-C on an otherwise fully booted Xavier?

hi @linuxdev,

Thanks for your advice.
I couldn’t figure out issue, so I just refresh the device, and now USB-C port is working.

I am facing another issue for serial debugging port, and I will report in another thread.