SDK Manager Installation Error

First of all, I am a newbie here and this is my first Jetpack installation attempt to the Xavier AGX.
I used “download now & install later” option to download necessary files and downloaded them successfully, now I am trying to install them. While installing, SDKM first indicates that OS image is being created (img1) and shortly after flashing begins, installation ends with errors (img2).
I also verify that Xavier is connected to my host (Ubuntu 18.04) by using lsusb command (“Bus 001 Device 008: ID 0955:7019 NVidia Corp.” is seen in the output, I think this means Xavier is correctly booted in recovery mode?)



The exported error logs file is here: (291.3 KB)

Any help is appreciated.

I am still unable to install and need help

This says to not even try to flash. The error at the “Flash Jetson OS” isn’t really an error, it is just doing what you told it to do.

FYI, when you flash the Jetson itself must be in recovery mode. You can run SDKM at any later date, and simply not use the “download and install later” option. The result, if the software release versions have not changed since the download, would be to flash using what you’ve already downloaded. If software has changed, then it would download again, followed by flash. Just make sure the Jetson has the right USB-C connected to the host, that the AGX Xavier is in recovery mode, and then run the flash software again without “download only”.

Yes, I am aware of that. First I downloaded the files using install later option, later when I had access to the Xavier, I tried installing (so I did not check the “download now & install later” checkbox when I had this porblem).
For the points you noted:

  • I am sure Xavier is connected to my host computer via a USB type-C cable.
  • I think Xavier is in recovery mode, because it is listed when I use lsusb command. Is there any other way to make sure it is really in recovery mode?
  • I ran the sdkm installation without “download only”

hello applereng,

it seems there’s connection issue before actually flashing the device,
for example,

*** Checking target board connection ... 1 connections found.
*** Reading ECID ... *** Error: ECID read failed.
Put the target board in RCM mode and retry.

could you please use the command-line to flash the target,
you may go to the installation path for the JetPack release image,
for example, /home/alperen/nvidia/nvidia_sdk/JetPack_4.5.1_Linux_JETSON_AGX_XAVIER/Linux_for_Tegra/
there’s script you’re able to perform image flashing manually.
you should still put device to enter forced-recovery mode, and please execute $ sudo ./ -r jetson-xavier mmcblk0p1 to burn the target,
you may share the results for reference if you still meet with failures.

1 Like

For recovery mode are you certain that the force recovery button is held down during either a power reset or powering on? You would not need to keep the recovery button on after that, but if the unit is fully booted (and not in recovery mode), then the lsusb would possibly mistake a device mode Jetson with a recovery mode Jetson…and actual flash would fail with a note about not being in recovery mode.

I managed to install eventually, but I still do not know the cause of this problem.
I tried installation on:

  • Ubuntu 18.04 (Dual Boot with windows)
  • Ubuntu 18.04 on VirtualBox
  • Ubuntu 16.04 on VMWare

I kept facing various different errors and problems in all these trials, finally the VMWare one worked.
There are a few things I can suggest to newbies like me, such as making sure there is enough disk space in the host (it was about ~40 GB for me), Xavier is really in recovery mode, downloaded files are not corrupted or incomplete. But I still don’t know the reasons or solutions of most of the problems I faced. It’s almost like its about luck.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.