Unable to Flash Jetson AGX Xavier in SDK manager

Hello, I recently got entered in Jetson Xavier, and tried to setup my board. Unfortunately, it did not work. I heard that you guys are experts, so I want to figure out what is wrong with my board.

First, I turned my board in recovery mode by pushing recovery button first and pushing power button and took off recovery button. Like the img, I used ‘lsusb’ in Linux terminals to find out that my board connected. The Linux is working on Virtualbox in my desktop, but I figured that usb does get recognized well.

Then, I turned my Xavier mode in spk manager as Manual Setup, because I don’t know the previous setting before me. (This board is not the first one. I got it from my laboratory due to my project.)
After that, I tried to flash the board, but it did not work and the manager came out with this warning.
: Could not detect target hardware. Please make sure the target hardware is connected and turned on, choose OK and Retry.

I also searched other logs and came out with these :

I tried other methods such as trying REC mode again, but without REC mode, the SDK manager could not recognize the board, so I think this is not a problem. Can you tell me what is the problem?


It looks like the VM is still causing sdkmanager not able to detect your device, even when you saw it in lsusb.

I would suggest you can find a native ubuntu host first.

BTW, I don’t understand what you want to say in below. Why is this not a problem? The only error I saw here is sdkm does not think your board is in recovery mode.

I tried other methods such as trying REC mode again, but without REC mode, the SDK manager could not recognize the board, so I think this is not a problem

There are still lots of things to check here. For example, actually we only support devkit carrier board here. If your board is not NV devkit, then you need to contact the board vendor first.

Also, if you didn’t use the correct type C port, then the flash would not work either.

Do you suggest to use Ubuntu in my Desktop directly by giving partitions?

I am not sure what does that mean by giving partitions.

You can use any kind of method. That does not matter to me. Just in case it is not a VM.

BTW, it has to be a x86 host.

Oh, I see. I was trying to say, that I should install Ubuntu in my desktop directly instead of using virtual machines such as VMware or Virtualbox.
BTW, does that mean I should not download x86 instead of ARM? I am so new to this subject, so I am not used to this topic. Thank you :)

Sdkmanager is based on x86 host. It will install files to the jeston which is ARM based device through the type C usb port on your carrier board.

My point is some other users think they can install sdkmanager on one jetson and use it to flash another jetson. Such jetson to flash jetson case is not supported.

Oh, I see. Can I ask you more if I have something else to question in Jetson?

Sure. Basically if the question is still related to flash board, then you can ask in this post.

If you want to ask something else, then you may file new topic.

There is another desktop at my house, but this cpu is not Intel, but AMD. Is it ok?

AMD (amd64) and Intel (x86_64) are compatible architectures. Either is interchangeable for this purpose and both will work.

Hey it’s me! I got the problem fixed since you told me to install Ubuntu at my desktop. However, another problem showed up. It says, “Cannot connect to the device via SSH. Check the user name and password, and make sure that SSH service is running on the device.” How can I solve this problem?

Does that show up after you flash the board or before you flash the board?

If you don’t know, then could you share the screenshot for what you saw?

After first flash, jetson will wait until you configure the user account on the monitor. If you don’t do that, then every function on jetson will not start. For example, ssh daemon.

Oh, I solved it. It was about putting the same name of the first settings. BTW, I have another question. Do I have to use the same IP address of the host computer?

What does that mean “same IP adress of the host computer”? The ssh is requesting you to use the ip of jetson.

Oh, I see. I misunderstood. Thank you!
Is there any site that I can refer to find some good topics for projects?

There are some posts over this forum.

Thank you! :)

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.