Unable to install Jetson SDK Target components with SDK Manager on Jetson AGX Xavier

Hello
I’m trying to install Jetson SDK Components on AGX Xavier with SDK Manager, the installation failed and the terminal of SDK Manager shows below:

12:44:11 SUMMARY: Flash Jetson AGX Xavier 16GB/32GB: Install completed successfully.
12:47:42 INFO: Start to check if only one device connected…
12:47:42 DEBUG: running command < true >

12:47:43 INFO: change working directory to /tmp
12:47:43 INFO: exec_command: ssh -F /dev/null -q -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no hirosawa@192.168.55.1 “dpkg-query -W -f=’${db:Status-abbrev} ${Version}’ cuda-toolkit-10-2”
12:47:43 INFO: [target] hirosawa@192.168.55.1’s password:
12:47:44 INFO: Target Deb package [{cuda-toolkit-10-2 10.2}] not installed; [deb_name]: cuda-repo-l4t-10-2-local-10.2.89_1.0-1_arm64.deb
12:47:44 ERROR: command terminated with error
12:47:44 DEBUG: running command < true >
12:47:44 INFO: command finished successfully
12:47:44 DEBUG: using adapter to query target component: NV_L4T_CUDNN_TARGET_POST_INSTALL_COMP version: 8.0 for bundle:
12:47:44 INFO: change working directory to /tmp
12:47:44 INFO: exec_command: ssh -F /dev/null -q -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no hirosawa@192.168.55.1 “dpkg-query -W -f=’${db:Status-abbrev} ${Version}’ libcudnn8”
12:47:44 INFO: [target] hirosawa@192.168.55.1’s password:
12:47:45 INFO: Target Deb package [{libcudnn8 8.0.0.180-1+cuda10.2}] not installed; [deb_name]: libcudnn8_8.0.0.180-1+cuda10.2_arm64.deb
12:47:45 ERROR: command terminated with error

It seems that ssh or scp failed to copy components to Jetson from Host computer.
I believe that the network works file because I’ve done following on my Host computer:

sudo -s
ssh <account_name>@192.168.55.1
ls -l # works

How to solve this problem?
I attached the log:
SDKM_logs_JetPack_4.4.1_Linux_for_Jetson_AGX_Xavier_2020-11-12_12-38-49.zip (160.3 KB)

Hi makoto,

The scp command is successful. The CUDA installation file is copied to /opt/nvidia/deb_repos/cuda-repo-l4t-10-2-local-10.2.89_1.0-1_arm64.deb on jetson device. However, the “sudo apt-get update” command has problem.

12:48:57.913 - info: NV_L4T_CUDA_TARGET_POST_INSTALL_COMP@JETSON_AGX_XAVIER: W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic/InRelease Could not resolve ‘ports.ubuntu.com
12:48:57.914 - info: NV_L4T_CUDA_TARGET_POST_INSTALL_COMP@JETSON_AGX_XAVIER: W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic-updates/InRelease Could not resolve ‘ports.ubuntu.com
12:48:57.914 - info: NV_L4T_CUDA_TARGET_POST_INSTALL_COMP@JETSON_AGX_XAVIER: W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic-backports/InRelease Could not resolve ‘ports.ubuntu.com
12:48:57.914 - info: NV_L4T_CUDA_TARGET_POST_INSTALL_COMP@JETSON_AGX_XAVIER: W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic-security/InRelease Could not resolve ‘ports.ubuntu.com
12:48:57.914 - info: NV_L4T_CUDA_TARGET_POST_INSTALL_COMP@JETSON_AGX_XAVIER: W: Failed to fetch https://repo.download.nvidia.com/jetson/common/dists/r32.4/InRelease Could not resolve ‘repo.download.nvidia.com
12:48:57.914 - info: NV_L4T_CUDA_TARGET_POST_INSTALL_COMP@JETSON_AGX_XAVIER: W: Failed to fetch https://repo.download.nvidia.com/jetson/t194/dists/r32.4/InRelease Could not resolve ‘repo.download.nvidia.com

It seems that there is DNS issue on the Jetson device.

Hi EdwardZhou-san, thanks for your reply.

My host computer of Jetson is connected to my company’s LAN which is configured to use proxy authentication.
So I tried following steps and found installation was a success.

  1. wait for ubuntu login screen on Jetson.
  2. login and create /etc/apt/apt.conf.d/90curtin-aptproxy file to use proxy authentication.
  3. start install of target components.

I think that proxy configuration of apt on Jetson should be done automatically,
because I write the same proxy settings on Settings menu of SDK Manager.
Anyway, thank you for your help.
I really appriciate it.

Hi makoto-san,

Thank you very much for your feedback. We’ll fix the proxy issue in future releases.